summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-02-26 12:18:55 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-27 10:03:53 +0100
commit8c3437ae495669f684d0f63f3ad3c62cedd059bb (patch)
treedf76c28f35cc56641fdde7df8b97570051583e2c /recipes-kernel/linux
parent351d72f3c0b3ac5b13ad438b33ff3e5019e70d64 (diff)
linux-toradex-mainline: refresh patch
Refresh patch against v6.3-rc1. Compare with commit 30233a229fdb ("thermal/drivers/imx: Use generic thermal_zone_get_trip() function") Rework linux-toradex-mainline-rt to have additionally its own directory for local files. Move the rt only files there and keep the old thermal patch version there. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/0001-thermal-imx-Update-critical-temp-threshold.patch15
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt-git/0001-thermal-imx-Update-critical-temp-threshold.patch39
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.cfg (renamed from recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.cfg)0
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.scc (renamed from recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.scc)0
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.cfg (renamed from recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.cfg)0
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.scc (renamed from recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.scc)0
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt_git.bb1
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb2
8 files changed, 49 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/0001-thermal-imx-Update-critical-temp-threshold.patch b/recipes-kernel/linux/linux-toradex-mainline-git/0001-thermal-imx-Update-critical-temp-threshold.patch
index 3fbd5e3..f62210c 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/0001-thermal-imx-Update-critical-temp-threshold.patch
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/0001-thermal-imx-Update-critical-temp-threshold.patch
@@ -1,4 +1,4 @@
-From 509dccde2a1cc4ac7d5099ca7aea9ec05c6f7e4f Mon Sep 17 00:00:00 2001
+From 07558dd2a672caca882d6a6ac03a1d7f061f6a1a Mon Sep 17 00:00:00 2001
From: Francesco Dolcini <francesco.dolcini@toradex.com>
Date: Wed, 20 Apr 2022 11:13:00 +0200
Subject: [PATCH] thermal: imx: Update critical temp threshold
@@ -18,10 +18,10 @@ Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/thermal/imx_thermal.c b/drivers/thermal/imx_thermal.c
-index 16663373b682..75a631a23e61 100644
+index fb0d5cab70af..0ff8cbedf560 100644
--- a/drivers/thermal/imx_thermal.c
+++ b/drivers/thermal/imx_thermal.c
-@@ -504,10 +504,10 @@ static void imx_init_temp_grade(struct platform_device *pdev, u32 ocotp_mem0)
+@@ -485,11 +485,11 @@ static void imx_init_temp_grade(struct platform_device *pdev, u32 ocotp_mem0)
}
/*
@@ -29,11 +29,12 @@ index 16663373b682..75a631a23e61 100644
+ * Set the critical trip point at max
* Set the passive trip point at 10 °C under max (changeable via sysfs)
*/
-- data->temp_critical = data->temp_max - (1000 * 5);
-+ data->temp_critical = data->temp_max;
- data->temp_passive = data->temp_max - (1000 * 10);
+ trips[IMX_TRIP_PASSIVE].temperature = data->temp_max - (1000 * 10);
+- trips[IMX_TRIP_CRITICAL].temperature = data->temp_max - (1000 * 5);
++ trips[IMX_TRIP_CRITICAL].temperature = data->temp_max;
}
+ static int imx_init_from_tempmon_data(struct platform_device *pdev)
--
-2.25.1
+2.35.3
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt-git/0001-thermal-imx-Update-critical-temp-threshold.patch b/recipes-kernel/linux/linux-toradex-mainline-rt-git/0001-thermal-imx-Update-critical-temp-threshold.patch
new file mode 100644
index 0000000..3fbd5e3
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt-git/0001-thermal-imx-Update-critical-temp-threshold.patch
@@ -0,0 +1,39 @@
+From 509dccde2a1cc4ac7d5099ca7aea9ec05c6f7e4f Mon Sep 17 00:00:00 2001
+From: Francesco Dolcini <francesco.dolcini@toradex.com>
+Date: Wed, 20 Apr 2022 11:13:00 +0200
+Subject: [PATCH] thermal: imx: Update critical temp threshold
+
+Increase the critical temperature threshold to the datasheet defined
+value according to the temperature grade of the SoC, increasing the
+actual critical temperature value of 5 degrees.
+
+Without this change the emergency shutdown will trigger earlier then
+required affecting applications that are expected to be working on this
+close to the limit, but yet valid, temperature range.
+
+Upstream-Status: Denied [https://lore.kernel.org/all/20220420091300.179753-1-francesco.dolcini@toradex.com/]
+Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
+---
+ drivers/thermal/imx_thermal.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/thermal/imx_thermal.c b/drivers/thermal/imx_thermal.c
+index 16663373b682..75a631a23e61 100644
+--- a/drivers/thermal/imx_thermal.c
++++ b/drivers/thermal/imx_thermal.c
+@@ -504,10 +504,10 @@ static void imx_init_temp_grade(struct platform_device *pdev, u32 ocotp_mem0)
+ }
+
+ /*
+- * Set the critical trip point at 5 °C under max
++ * Set the critical trip point at max
+ * Set the passive trip point at 10 °C under max (changeable via sysfs)
+ */
+- data->temp_critical = data->temp_max - (1000 * 5);
++ data->temp_critical = data->temp_max;
+ data->temp_passive = data->temp_max - (1000 * 10);
+ }
+
+--
+2.25.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.cfg b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.cfg
index a9c88bd..a9c88bd 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.cfg
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.cfg
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.scc b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.scc
index edd1519..edd1519 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt-less-latency.scc
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt-less-latency.scc
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.cfg b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.cfg
index 17b06b1..17b06b1 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.cfg
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.cfg
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.scc b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.scc
index 82d27dc..82d27dc 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/preempt-rt.scc
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt-git/preempt-rt.scc
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
index e40df42..2cbf080 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
@@ -1,5 +1,6 @@
LINUX_VERSION ?= "6.2-rc"
require recipes-kernel/linux/linux-toradex-mainline_git.bb
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-git:"
SUMMARY = "Toradex mainline real-time Linux kernel"
# To build the RT kernel we use the RT kernel git repo rather than applying
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index 7180eef..cbb751f 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -3,7 +3,7 @@ SECTION = "kernel"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM ?= "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-git:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-toradex-mainline-git:"
DEPENDS += "coreutils-native"