summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-10-02 16:29:27 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-12-16 19:20:43 +0100
commit268c0582b879c8c0e7e57c8a5719524b678ff9f3 (patch)
treef1f566e9967fe4142e9e1aace800527d07a203a5 /recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch
parentd049426c8c76c92716aedec75e008157707c4ac3 (diff)
linux-toradex-mainline: switch to use kernel.org
Currently this builds kernel 5.16.0-RC5 from kernel.org. With the override `use-head-next` set, the HEAD of the master branch is built instead. For the rt patches a git repository from kernel.org with a maintained branch which regularly merges in the stable/master git trees is used. This changes from using defconfigs provided from the kernel sources to use defconfigs which the recipe provides. Get the initial defconfig from the kernel sources as of commit 2585cf9dfaad Linux 5.16-rc5. "imx_v6_v7_defconfig" for i.MX 32 bit SoC "tegra_defconfig" for TK1 "defconfig" for i.MX 64 bit SoC Run them through 'make *defconfig; make savedefconfig' first. Kernel 5.16 introduced that the device tree files are validated if built in the way OE builds them. Port the solution to make this from the linux-yocto-dev.bb recipe, commit c12a91827e88 ("linux-yocto-dev: introduce dt-validation PACKAGECONFIG") which is cleaner than reverting the commit that introduced the validation. Related-to: ELB-4094 Related-to: ELB-4095 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch
new file mode 100644
index 0000000..f057fea
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-kbuild-Enable-DT-schema-checks-for-.dtb-targe.patch
@@ -0,0 +1,40 @@
+From 8f473db4c3a5abbf11dcb870b08df63d7e48d6d5 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Sun, 26 Sep 2021 11:45:56 +0000
+Subject: [PATCH] Revert "kbuild: Enable DT schema checks for %.dtb targets"
+
+This reverts commit 53182e81f47d4ea0c727c49ad23cb782173ab849.
+---
+ Makefile | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index aa46d25e4f90..82737001bdf7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1510,17 +1510,17 @@ endif
+
+ ifneq ($(dtstree),)
+
+-%.dtb: dt_binding_check include/config/kernel.release scripts_dtc
+- $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@ $(dtstree)/$*.dt.yaml
++%.dtb: include/config/kernel.release scripts_dtc
++ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
+
+-%.dtbo: dt_binding_check include/config/kernel.release scripts_dtc
+- $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@ $(dtstree)/$*.dt.yaml
++%.dtbo: include/config/kernel.release scripts_dtc
++ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
+
+ PHONY += dtbs dtbs_install dtbs_check
+ dtbs: include/config/kernel.release scripts_dtc
+ $(Q)$(MAKE) $(build)=$(dtstree)
+
+-ifneq ($(filter dtbs_check %.dtb %.dtbo, $(MAKECMDGOALS)),)
++ifneq ($(filter dtbs_check, $(MAKECMDGOALS)),)
+ export CHECK_DTBS=y
+ dtbs: dt_binding_check
+ endif
+--
+2.20.1
+