summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-04-01 11:15:53 +0200
committerMing Liu <ming.liu@toradex.com>2022-04-01 11:15:53 +0200
commitcb27105ebfaf0fb5ab84429d37455cfcd2e3ad22 (patch)
tree1d0d1269353db1e88d066866a500d513dfe3537a /recipes-graphics
parent44341df4b79ccdf2072d0f2a49ce7893e321dfef (diff)
weston-init: move in weston-init recipe from meta-toradex-nxp
Also fix several issues as follows: - Drop INI_UNCOMMENT_ASSIGNMENTS append, the correct fix has been merged to meta-freescale by commit: 6be9870b505. - Replace configure_noidle by no-idle-timeout PACKAGECONFIG. - Replace configure_pixman by use-pixman PACKAGECONFIG. - Install weston env setup profile. - Run weston systemd service as root user, this ensures input devices and GPU acceleration hardwares, reference: https://source.codeaurora.org/external/imx/meta-imx/commit/?h=hardknott-5.10.72-2.2.0&id=9e08be758765d4a991e0a440f8abef225be094e3 Related-to: ELB-3477 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 0000000..494db7c
--- /dev/null
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,19 @@
+PACKAGECONFIG:append:upstream:tdx = " no-idle-timeout"
+PACKAGECONFIG:append:upstream:colibri-imx6ull = " use-pixman"
+PACKAGECONFIG:append:upstream:colibri-imx6ull-emmc = " use-pixman"
+PACKAGECONFIG:append:upstream:colibri-imx7 = " use-pixman"
+PACKAGECONFIG:append:upstream:colibri-imx7-emmc = " use-pixman"
+
+do_install:append:tdx() {
+ # profile is from meta-freescale-distro layer but only being installed for fsl,fslc distros
+ # we need install it for Toradex distros here.
+ install -Dm0755 ${WORKDIR}/profile ${D}${sysconfdir}/profile.d/weston.sh
+
+ # We need run weston systemd service with root user, or else it could not
+ # access input devices and GPU acceleration hardwares
+ # Reference: https://source.codeaurora.org/external/imx/meta-imx/commit/?h=hardknott-5.10.72-2.2.0&id=9e08be758765d4a991e0a440f8abef225be094e3
+ sed -i "s/User=weston/User=root/" ${D}${systemd_system_unitdir}/weston.service
+ sed -i "s/Group=weston/Group=root/" ${D}${systemd_system_unitdir}/weston.service
+ sed -i "s/SocketUser=weston/SocketUser=root/" ${D}${systemd_system_unitdir}/weston.socket
+ sed -i "s/SocketGroup=wayland/SocketUser=root/" ${D}${systemd_system_unitdir}/weston.socket
+}