summaryrefslogtreecommitdiff
path: root/recipes-core/udev/udev-toradex-rules.bb
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-08-03 18:59:57 +0300
committerMax Krummenacher <max.krummenacher@toradex.com>2020-09-14 09:46:53 +0200
commite9950a3a638a8b13cfd566ba78cbdeec4da586bb (patch)
tree45ae7f3ab545ddae0c4ee475c3cb283cee7f0610 /recipes-core/udev/udev-toradex-rules.bb
parent9de495e99756b66fc2a5d5599a26339fcca5cc53 (diff)
apalis-imx6: udev: add symlink to adc raw data
Create symlinks for each supported by Apalis iMX6 ADC channels, standardizing names as apalis-adcX, according to the Apalis signal names table. Related-to: ELB-2839 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com> (cherry picked from commit 41ebdf6d19a1b8af2e06f274d711823bdb345f29)
Diffstat (limited to 'recipes-core/udev/udev-toradex-rules.bb')
-rw-r--r--recipes-core/udev/udev-toradex-rules.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-toradex-rules.bb b/recipes-core/udev/udev-toradex-rules.bb
index dc6248a..a4833ca 100644
--- a/recipes-core/udev/udev-toradex-rules.bb
+++ b/recipes-core/udev/udev-toradex-rules.bb
@@ -4,11 +4,14 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "\
file://99-toradex.rules \
file://10-toradex-wifi-ifnames.link \
+ file://toradex-adc.sh \
"
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
+ install -d ${D}${sysconfdir}/udev/scripts
install -d ${D}${sysconfdir}/systemd/network
install -m 0644 ${WORKDIR}/99-toradex.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0755 ${WORKDIR}/toradex-adc.sh ${D}${sysconfdir}/udev/scripts/
install -m 0644 ${WORKDIR}/10-toradex-wifi-ifnames.link ${D}${sysconfdir}/systemd/network/
}