summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorFrancesco Dolcini <francesco.dolcini@toradex.com>2022-08-08 15:20:09 +0200
committerFrancesco Dolcini <francesco.dolcini@toradex.com>2022-08-08 15:39:21 +0200
commite4f0f9dda029026655402ebc80a17a00e30ffa5c (patch)
tree5b3a1848fb25baf45c37e983d14f9355a4fe409d /recipes-bsp
parenta4a281480273ef56aa22078905851d39ee135148 (diff)
u-boot: Add patch to enable `boot` on colibri-imx7
Add patch to enable `boot` command on colibri-imx7, submitted in https://lore.kernel.org/all/20220803112009.271563-1-francesco.dolcini@toradex.com/ Related-to: ELB-4642 Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/0013-configs-colibri-imx7-Enable-bootd-command.patch44
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend1
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0013-configs-colibri-imx7-Enable-bootd-command.patch b/recipes-bsp/u-boot/u-boot/0013-configs-colibri-imx7-Enable-bootd-command.patch
new file mode 100644
index 0000000..c7b17c2
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0013-configs-colibri-imx7-Enable-bootd-command.patch
@@ -0,0 +1,44 @@
+From 76cc934ba0ee5e374b673f62a3442daca74e6f44 Mon Sep 17 00:00:00 2001
+From: Francesco Dolcini <francesco.dolcini@toradex.com>
+Date: Wed, 27 Jul 2022 17:40:46 +0200
+Subject: [PATCH] configs: colibri-imx7: Enable bootd command
+
+Enable boot/bootd command in toradex colibri-imx7 defconfig,
+it's just convenient to have it in and every other toradex board
+already includes it.
+
+Upstream-Status: Submitted [https://lore.kernel.org/all/20220803112009.271563-1-francesco.dolcini@toradex.com/]
+Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
+Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+---
+ configs/colibri_imx7_defconfig | 1 -
+ configs/colibri_imx7_emmc_defconfig | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/configs/colibri_imx7_defconfig b/configs/colibri_imx7_defconfig
+index 973afc1a2b4b..e0de7f1ab18d 100644
+--- a/configs/colibri_imx7_defconfig
++++ b/configs/colibri_imx7_defconfig
+@@ -25,7 +25,6 @@ CONFIG_SYS_CONSOLE_IS_IN_ENV=y
+ CONFIG_DISPLAY_BOARDINFO_LATE=y
+ CONFIG_BOARD_LATE_INIT=y
+ CONFIG_SYS_PROMPT="Colibri iMX7 # "
+-# CONFIG_CMD_BOOTD is not set
+ # CONFIG_BOOTM_PLAN9 is not set
+ # CONFIG_BOOTM_RTEMS is not set
+ # CONFIG_CMD_IMI is not set
+diff --git a/configs/colibri_imx7_emmc_defconfig b/configs/colibri_imx7_emmc_defconfig
+index 01b1cb8b5520..e4083b55c3a8 100644
+--- a/configs/colibri_imx7_emmc_defconfig
++++ b/configs/colibri_imx7_emmc_defconfig
+@@ -24,7 +24,6 @@ CONFIG_SYS_CONSOLE_IS_IN_ENV=y
+ CONFIG_DISPLAY_BOARDINFO_LATE=y
+ CONFIG_BOARD_LATE_INIT=y
+ CONFIG_SYS_PROMPT="Colibri iMX7 # "
+-# CONFIG_CMD_BOOTD is not set
+ # CONFIG_BOOTM_PLAN9 is not set
+ # CONFIG_BOOTM_RTEMS is not set
+ # CONFIG_CMD_IMI is not set
+--
+2.25.1
+
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index c972fee..75ed1d8 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -21,6 +21,7 @@ TDX_PATCHES = " \
file://0010-toradex-common-Remove-ifdef-usage-for-2nd-ethaddr.patch \
file://0011-toradex-tdx-cfg-block-Use-official-SKU-names.patch \
file://0012-toradex-common-Improve-product-serial-print-during-b.patch \
+ file://0013-configs-colibri-imx7-Enable-bootd-command.patch \
"
# patches which are not (yet) in the latest master
TDX_PATCHES:use-head-next = " \