summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-02-20 16:08:51 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-02-28 13:55:38 +0100
commita3c89838f21fa5ecca6aa1c39c26094a94944711 (patch)
tree490316b931c35462aca6d6db9485fdef38189cdf /recipes-bsp
parent882cb054a260998c6b2bb6a26e8c963b7ce22216 (diff)
layer: rework recipes to use soc familiy overrides
Follow meta-freescale commit 30f5ce1d ("Generalize overrides subsystem for NXP and Mainline support"). Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index c8ac4db..8988bcb 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -33,8 +33,8 @@ do_compile:append:colibri-vf () {
nand_padding
}
-BOOT_TOOLS:mx8m = "imx-boot-tools"
-do_deploy:append:mx8m() {
+BOOT_TOOLS = "imx-boot-tools"
+do_deploy:append:mx8m-generic-bsp() {
# Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
if [ -n "${UBOOT_CONFIG}" ]
then