summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorIgor Opaniuk <igor.opaniuk@gmail.com>2020-05-26 11:12:28 +0300
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-09 18:33:45 +0200
commit27f8374d0cda99088a182e7716ffa1ebdf78bcfc (patch)
tree7daccd0e4f023dae55690c1187d0e3dfca8d4ca6 /recipes-bsp
parentd72a9bde1eb8deade42b36156b546388a634053b (diff)
device-tree-overlays: add initial recipe
Add external device tree overlays to be build outside of the main linux kernel recipe. Relates-to: ELB-2723 Signed-off-by: Ming Liu <ming.liu@toradex.com> Signed-off-by: Igor Opaniuk <igor.opaniuk@gmail.com> Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit 73f6a666f28d9719c40136998a68b00b2c1848d1)
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/device-tree-overlays/device-tree-overlays_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/device-tree-overlays/device-tree-overlays_git.bb b/recipes-bsp/device-tree-overlays/device-tree-overlays_git.bb
new file mode 100644
index 0000000..05a58a2
--- /dev/null
+++ b/recipes-bsp/device-tree-overlays/device-tree-overlays_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Toradex BSP device tree overlays"
+DESCRIPTION = "Toradex BSP device tree overlays from within layer."
+
+SRC_URI = "git://git.toradex.com/device-tree-overlays.git;branch=${SRCBRANCH};protocol=https"
+
+SRCBRANCH = "toradex_4.14-2.3.x-imx"
+SRCBRANCH_use-mainline-bsp = "toradex_5.4.y"
+
+SRCREV = "fc95c1137968488a172c45dc66813fd3e79286e8"
+SRCREV_use-mainline-bsp = "f73d8b1caf5b6b837ed39e2bdd60040163d43c56"
+SRCREV_use-head-next = "${AUTOREV}"
+
+PV = "1.0.0+git${SRCPV}"
+
+inherit devicetree
+
+S = "${WORKDIR}/git/overlays"
+
+COMPATIBLE_MACHINE = ".*(mx[678]|tegra124).*"