summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-22 11:47:18 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-22 12:57:59 +0100
commitca087a4d77acd0752ff5447d4c8156e8761ee528 (patch)
tree35e4daf591335d848482a2dc60f582ee1c8f2ae4 /recipes-bsp/u-boot/u-boot_%.bbappend
parent33451fb0e305f4e054896b604b1c0ca03d9b5ec7 (diff)
u-boot-toradex: colibri-imx7: boot linux kernel in non-secure/secure mode
While NXP i.MX 7 downstream requires the Linux kernel to boot in secure mode mainline/upstream requires non-secure mode instead, as it properly uses PSCI to control further cores. Mainline boots in non-secure mode by default. Add the appropriate environment variable if building a downstream kernel. Related-to: ELB-4090 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_%.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index dd62328..c8ac4db 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,5 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
SRCREV:use-head-next = "${AUTOREV}"
+SRC_URI:append:use-nxp-bsp = " \
+ file://0001-colibri_imx7-boot-linux-kernel-in-secure-mode.patch \
+"
+
PADDING_DIR = "${B}"
nand_padding () {
# pad the end of U-Boot with 0x00 up to the the end of the CSF area