summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-distro-boot.bb
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2021-03-24 13:27:52 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-05-24 18:21:53 +0200
commit2c6be9d5975548af9638d6e8250333419d8f132c (patch)
tree9fe9b5705368a22379775b839f3dbbbd6b496ed1 /recipes-bsp/u-boot/u-boot-distro-boot.bb
parent04887d9cde8954741dc263231e4f863c4b88eb1c (diff)
u-boot-distro-boot: explicitly use bootm for booting fitImage
We cant use a single KERNEL_BOOTCMD for both fit/non-fit kernel images, that makes a invalid bootcmd being used in boot.scr either for fit or for non-fit image. Let's change to explicitly use 'bootm' for booting fitimage. Related-to: TOR-1700 Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit c4bd1adef88e337f37cf3c88d53a7d61d3a4441b)
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-distro-boot.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 97fa88f..596d6df 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -9,8 +9,8 @@ SRC_URI = " \
file://boot.cmd.in \
"
-KERNEL_BOOTCMD ??= "${@'bootm' if d.getVar('KERNEL_IMAGETYPE') == 'fitImage' else 'bootz'}"
-KERNEL_BOOTCMD_aarch64 ?= "${@'bootm' if d.getVar('KERNEL_IMAGETYPE') == 'fitImage' else 'booti'}"
+KERNEL_BOOTCMD ??= "bootz"
+KERNEL_BOOTCMD_aarch64 ?= "booti"
inherit deploy