summaryrefslogtreecommitdiff
path: root/openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-08-09 16:54:38 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:35:15 +0200
commit617e615193dd297f1cb5e4be29677c7e24803d97 (patch)
treed638b709c0da5a275a08d618c4339c34741ebe1a /openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend
parent71a8f744943ae4358ea414d743be8ae8cfceb9fa (diff)
meta-openembedded layer bbappends
Move the appends on recipe's which are not in an essential required layer into a target layer specific directory and add them only if said layer is active in build/conf/bblayers.conf. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend')
-rw-r--r--openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend b/openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend
new file mode 100644
index 0000000..ceb009d
--- /dev/null
+++ b/openembedded-layer/recipes-support/libusbg/libusbg_git.bbappend
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/libusbg:"
+
+PV = "0.1.0-git"
+
+SRCREV = "93631e618436989ebd7e9df2c997c175feb14bda"
+SRC_URI = "git://github.com/kopasiak/libusbg.git \
+ file://usbg.service \
+ file://g1.schema \
+"
+
+DEPENDS = "libconfig"
+
+inherit autotools pkgconfig systemd
+
+do_install_append () {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/usbg.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sysconfdir}/usbg/
+ install -m 0644 ${WORKDIR}/g1.schema ${D}${sysconfdir}/usbg/g1.schema
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "usbg.service"