summaryrefslogtreecommitdiff
path: root/classes
diff options
context:
space:
mode:
authorEmanuele Ghidoli <emanuele.ghidoli@toradex.com>2023-05-03 18:18:57 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-06-28 11:14:21 +0200
commit4ec9061a302615c7eba6a260b15b995d108bdb23 (patch)
treee35c2a9b355647080445dd9fbe044910a7c1ba1e /classes
parent112eb65d639ed89c6720ca085522c9abb5d7de77 (diff)
image_type_tezi: fix not working NXP EULA download
Download of NXP EULA was always failing because the network access was disabled during execution of do_image_teziimg task. The download is not mandatory and it falls back using the EULA provided by recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb. Fix by setting the network flag on do_image_teziimg task. This flag must be set for every task that access network from bitbake 2.0 which is used starting from Kirkstone [1]. [1] http://git.openembedded.org/bitbake/commit/?id=0746b6a2a32fec4c18bf1a52b1454ca4c04bf543 Related-to: ELB-5161 Signed-off-by: Emanuele Ghidoli <emanuele.ghidoli@toradex.com> (cherry picked from commit 24404926b8689435af675c5a9127b48d91e418d0)
Diffstat (limited to 'classes')
-rw-r--r--classes/image_type_tezi.bbclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/classes/image_type_tezi.bbclass b/classes/image_type_tezi.bbclass
index 44bdcd0..a81b2b0 100644
--- a/classes/image_type_tezi.bbclass
+++ b/classes/image_type_tezi.bbclass
@@ -405,3 +405,4 @@ do_image_teziimg[cleandirs] += "${WORKDIR}/image-json"
do_image_teziimg[prefuncs] += "${TEZI_IMAGE_TEZIIMG_PREFUNCS}"
do_image_teziimg[recrdeptask] += "do_deploy"
do_image_teziimg[vardepsexclude] = "TEZI_VERSION TEZI_DATE"
+do_image_teziimg[network] = "1"