summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxtask/lxtask_0.1.10.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-12-08 13:47:03 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-12-08 14:55:41 +0100
commita06061d01d8f3a7863fcd1077ccb516f80c842b4 (patch)
tree512d195ca0652a971ba0ea76df1fb6602f5c94ce /recipes-lxde/lxtask/lxtask_0.1.10.bb
parentcdc739dc90b8c533cef1a60deca709044cd837c2 (diff)
lxtask: update to 0.1.10
This fixes link errors with gcc 10. | ...ld: lxtask-callbacks.o:.../lxtask-0.1.9/src/interface.h:64: multiple definition of `column'; | lxtask-main.o:.../lxtask-0.1.9/src/interface.h:64: first defined here Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-lxde/lxtask/lxtask_0.1.10.bb')
-rw-r--r--recipes-lxde/lxtask/lxtask_0.1.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-lxde/lxtask/lxtask_0.1.10.bb b/recipes-lxde/lxtask/lxtask_0.1.10.bb
new file mode 100644
index 0000000..fa30ec3
--- /dev/null
+++ b/recipes-lxde/lxtask/lxtask_0.1.10.bb
@@ -0,0 +1,22 @@
+SUMMARY = "LXDE task manager"
+HOMEPAGE = "http://lxde.org/"
+SECTION = "x11"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "glib-2.0 glib-2.0-native intltool-native virtual/libintl"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxtask-${PV}.tar.xz"
+SRC_URI[md5sum] = "27b5258847afc237a5b89666e7a8b45b"
+SRC_URI[sha256sum] = "2216df9bc4bb2d80733e788966512ac58c421e0a0a1ff85210f34a29d1eb4e2c"
+
+PACKAGECONFIG ?= "gtk3"
+PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
+python __anonymous () {
+ depends = d.getVar("DEPENDS", d, 1)
+ if 'gtk3' not in d.getVar('PACKAGECONFIG', True):
+ d.setVar("DEPENDS", "%s gtk+" % depends)
+}
+
+inherit autotools pkgconfig gettext