summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/device-tree-overlays-ti_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/device-tree-overlays-ti_git.bb')
-rw-r--r--recipes-kernel/linux/device-tree-overlays-ti_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/linux/device-tree-overlays-ti_git.bb b/recipes-kernel/linux/device-tree-overlays-ti_git.bb
new file mode 100644
index 0000000..5ab8961
--- /dev/null
+++ b/recipes-kernel/linux/device-tree-overlays-ti_git.bb
@@ -0,0 +1,17 @@
+inherit toradex-devicetree
+
+SRCBRANCH = "toradex_5.15-2.1.x-imx"
+SRCREV = "f12e5aa29974854314fee808602a9c0dfc3ac814"
+SRCREV:use-head-next = "${AUTOREV}"
+
+# we have dtbo's in arm and arm64 architecture, set the include paths
+# to include both architectures.
+KERNEL_INCLUDE = " \
+ ${STAGING_KERNEL_DIR}/arch/arm/boot/dts \
+ ${STAGING_KERNEL_DIR}/arch/arm/boot/dts*/* \
+ ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts \
+ ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/* \
+ ${STAGING_KERNEL_DIR}/scripts/dtc/include-prefixes \
+"
+
+COMPATIBLE_MACHINE = "am62xx"