summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb24
1 files changed, 10 insertions, 14 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 5c50898..bb5a5c1 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "ca551722e0b5341282a2dd346ddd1897db47cb5b"
+SRCREV = "896eec92715d7062963d92bedd7dc61d643df1ea"
SRCREV:use-head-next = "${AUTOREV}"
SRCBRANCH = "toradex_ti-u-boot-2023.04"
@@ -23,28 +23,24 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-# preserve and deploy u-boot-initial-env if building for the Cortex-A53 core
-# even if u-boot-ti.inc do_deploy() tries to delete it.
-DEPLOY_INITIAL_ENV = "install -D -m 644 ${B}/sd/u-boot-initial-env ${DEPLOYDIR}/ || true"
-DEPLOY_INITIAL_ENV:k3r5 = ":"
-do_deploy:append () {
- ${DEPLOY_INITIAL_ENV}
-}
do_deploy:append:k3r5 () {
+ # remove any u-boot-initial-env* file not already removed by the
+ # u-boot-ti.inc
+ rm -f ${DEPLOYDIR}/u-boot-initial-env*
+
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do
- if [ x${config} = "xverdin-am62_r5_usbdfu_defconfig" ]
- then
- TARGETSUFFIX="-dfu"
- else
- TARGETSUFFIX=""
- fi
i=$(expr $i + 1);
for type in ${UBOOT_CONFIG}; do
j=$(expr $j + 1);
if [ $j -eq $i ]
then
+ if [ "${type}" = "${UBOOT_DFU_CONFIG}" ]; then
+ TARGETSUFFIX="-dfu"
+ else
+ TARGETSUFFIX=""
+ fi
for f in ${B}/${config}/tiboot3-*.bin; do
if [ -f "$f" ]; then
TARGET=$(basename $f)${TARGETSUFFIX}