summaryrefslogtreecommitdiff
path: root/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'qt5-layer/recipes-qt/qt5/qtbase_%.bbappend')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend34
1 files changed, 17 insertions, 17 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 426640e..72bc506 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,13 +1,13 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-# am62xx extra gles2 packageconfig flags
-GLES_EXTRA_DEPS:am62xx = "libdrm wayland"
-# rename from gles2 to gles2extra to preserve the original one for non am62xx machines
+# TI k3 extra gles2 packageconfig flags
+GLES_EXTRA_DEPS:k3 = "libdrm wayland"
+# rename from gles2 to gles2extra to preserve the original one for non k3 machines
PACKAGECONFIG[gles2extra] = "-opengl es2 -eglfs,,virtual/libgles2 virtual/egl ${GLES_EXTRA_DEPS}"
-PR:append:am62xx = ".arago17"
+PR:append:k3 = ".arago17"
-QT_CONFIG_FLAGS:append:am62xx = " -qpa ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'eglfs', d)}"
+QT_CONFIG_FLAGS:append:k3 = " -qpa ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'eglfs', d)}"
QT_EGLFS_PATCHES = "\
file://0001-calculator-Add-exit-button-for-non-window-environmen.patch \
@@ -17,14 +17,14 @@ QT_EGLFS_PATCHES = "\
# file://0002-deform-disable-opengl-button.patch
-SRC_URI:append:am62xx = "\
+SRC_URI:append:k3 = "\
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', "${QT_EGLFS_PATCHES}", d)}\
file://0001-deform-Fix-how-controls-are-shown.patch \
file://0001-qtbase-plugins-platforms-eglfs_kms-fix-compiler-erro.patch \
file://0001-eglfs-Force-888-format-only-on-env-flag.patch \
"
-python do_patch:append:am62xx () {
+python do_patch:append:k3 () {
import shutil
work_dir = d.getVar("WORKDIR")
@@ -35,30 +35,30 @@ python do_patch:append:am62xx () {
}
# Add symbolic link qt5/examples for backward compatibility
-do_install:append:am62xx () {
+do_install:append:k3 () {
install -d ${D}${datadir}/qt5
ln -sf ../examples ${D}${datadir}/qt5/examples
}
-FILES:${PN}-examples:append:am62xx = " ${datadir}/qt5/*"
+FILES:${PN}-examples:append:k3 = " ${datadir}/qt5/*"
-RDEPENDS:${PN}:am62xx += "${PN}-conf"
+RDEPENDS:${PN}:k3 += "${PN}-conf"
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"
############################### TDX added
# from meta-arago/conf/layer.conf
-PACKAGECONFIG_GL:am62xx = "gles2extra linuxfb"
-PACKAGECONFIG_DISTRO:am62xx = "icu examples accessibility gif gbm kms libinput"
-PACKAGECONFIG_FONTS:am62xx = "fontconfig"
+PACKAGECONFIG_GL:k3 = "gles2extra linuxfb"
+PACKAGECONFIG_DISTRO:k3 = "icu examples accessibility gif gbm kms libinput"
+PACKAGECONFIG_FONTS:k3 = "fontconfig"
-PACKAGECONFIG:remove:am62xx = "kms"
-PACKAGECONFIG:remove:am62xx = "vulkan"
-PACKAGECONFIG:remove:am62xx = "glib xcb"
+PACKAGECONFIG:remove:k3 = "kms"
+PACKAGECONFIG:remove:k3 = "vulkan"
+PACKAGECONFIG:remove:k3 = "glib xcb"
# they don't apply without changes, drop them for now
SRC_URI:remove = " \
file://0002-deform-disable-opengl-button.patch \