summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index a5a9ce0..67c1639 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -34,6 +34,12 @@ do_deploy:append:k3r5 () {
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do
+ if [ x${config} = "xverdin-am62_r5_usbdfu_defconfig" ]
+ then
+ TARGETSUFFIX="-dfu"
+ else
+ TARGETSUFFIX=""
+ fi
i=$(expr $i + 1);
for type in ${UBOOT_CONFIG}; do
j=$(expr $j + 1);
@@ -41,7 +47,8 @@ do_deploy:append:k3r5 () {
then
for f in ${B}/${config}/tiboot3-*.bin; do
if [ -f "$f" ]; then
- install -m 644 $f ${DEPLOYDIR}/
+ TARGET=$(basename $f)${TARGETSUFFIX}
+ install -m 644 $f ${DEPLOYDIR}/${TARGET}
fi
done