summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-07-27 12:11:38 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-07-27 12:15:28 +0200
commite305a778dabba2984b4694d9a36af3a99de7b1ea (patch)
tree898effaa60f011f22324b166b7994fa03d5aeabb
parent6021bd70adbbecb2329e97a05208892b12e1352a (diff)
u-boot-toradex-ti: deploy dfu tiboot3 binaries
With the move to use binman to create the tiboot3 binaries also handle the case where we build tiboot3 for use over DFU. I.e. deploy them with the '-dfu' suffix which we expect when assembling the Toradex Easy Installer image. Related-to: TEI-1100 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index a5a9ce0..67c1639 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -34,6 +34,12 @@ do_deploy:append:k3r5 () {
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do
+ if [ x${config} = "xverdin-am62_r5_usbdfu_defconfig" ]
+ then
+ TARGETSUFFIX="-dfu"
+ else
+ TARGETSUFFIX=""
+ fi
i=$(expr $i + 1);
for type in ${UBOOT_CONFIG}; do
j=$(expr $j + 1);
@@ -41,7 +47,8 @@ do_deploy:append:k3r5 () {
then
for f in ${B}/${config}/tiboot3-*.bin; do
if [ -f "$f" ]; then
- install -m 644 $f ${DEPLOYDIR}/
+ TARGET=$(basename $f)${TARGETSUFFIX}
+ install -m 644 $f ${DEPLOYDIR}/${TARGET}
fi
done