summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-10 12:03:05 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-10 12:09:30 +0200
commit6ad496b724d27fdd9d3227931fab34fa34d53f53 (patch)
tree4ec48c77e5d31a36c04120ba072bebdb0dfb66cf
parent7b64c52cad283964691e6b1e0a1f1cea00bbc2d8 (diff)
machines: k3r5: fix uboot_config configuration type names
UBOOT_CONFIG was changed to use 'sd' as one of the configs built for the R5 SPL. However the same is already in use when building the TEZI specific U-Boot for the Cortex A53 and is set from within the TEZI distro. Thus the two configuration clash and the build fails. Change the config name to include the suffix '-r5' to have the two seperate. Fixes: 979d850 ("verdin-am62-k3r5: drop -gp from the u-boot config names") Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/aquila-am69-k3r5.conf8
-rw-r--r--conf/machine/verdin-am62-k3r5.conf8
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb2
3 files changed, 9 insertions, 9 deletions
diff --git a/conf/machine/aquila-am69-k3r5.conf b/conf/machine/aquila-am69-k3r5.conf
index dcdc8ac..1936224 100644
--- a/conf/machine/aquila-am69-k3r5.conf
+++ b/conf/machine/aquila-am69-k3r5.conf
@@ -17,10 +17,10 @@ SYSFW_SOC = "am69"
SYSFW_CONFIG = "aquila"
SYSFW_SUFFIX = "hs-fs"
-UBOOT_DFU_CONFIG = "dfu"
+UBOOT_DFU_CONFIG = "dfu-r5"
# The DFU config does not (yet) exist in upstream. It is needed only
# if booting from DFU/USB.
UBOOT_DFU_CONFIG:upstream = ""
-UBOOT_CONFIG ??= "${UBOOT_DFU_CONFIG} sd"
-UBOOT_CONFIG[dfu] = "aquila-am69_r5_usbdfu_defconfig,dfu,spl/u-boot-spl.bin"
-UBOOT_CONFIG[sd] = "aquila-am69_r5_defconfig,sdcard,spl/u-boot-spl.bin"
+UBOOT_CONFIG ??= "${UBOOT_DFU_CONFIG} sd-r5"
+UBOOT_CONFIG[dfu-r5] = "aquila-am69_r5_usbdfu_defconfig,dfu,spl/u-boot-spl.bin"
+UBOOT_CONFIG[sd-r5] = "aquila-am69_r5_defconfig,sdcard,spl/u-boot-spl.bin"
diff --git a/conf/machine/verdin-am62-k3r5.conf b/conf/machine/verdin-am62-k3r5.conf
index 7d92e3c..700968e 100644
--- a/conf/machine/verdin-am62-k3r5.conf
+++ b/conf/machine/verdin-am62-k3r5.conf
@@ -16,10 +16,10 @@ SYSFW_SOC = "am62x"
SYSFW_CONFIG = "verdin"
SYSFW_SUFFIX = "hs-fs"
-UBOOT_DFU_CONFIG = "dfu"
+UBOOT_DFU_CONFIG = "dfu-r5"
# The DFU config does not (yet) exist in upstream. It is needed only
# if booting from DFU/USB.
UBOOT_DFU_CONFIG:upstream = ""
-UBOOT_CONFIG ??= "${UBOOT_DFU_CONFIG} sd"
-UBOOT_CONFIG[dfu] = "verdin-am62_r5_usbdfu_defconfig,dfu,spl/u-boot-spl.bin"
-UBOOT_CONFIG[sd] = "verdin-am62_r5_defconfig,sdcard,spl/u-boot-spl.bin"
+UBOOT_CONFIG ??= "${UBOOT_DFU_CONFIG} sd-r5"
+UBOOT_CONFIG[dfu-r5] = "verdin-am62_r5_usbdfu_defconfig,dfu,spl/u-boot-spl.bin"
+UBOOT_CONFIG[sd-r5] = "verdin-am62_r5_defconfig,sdcard,spl/u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 74ea005..bb5a5c1 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -36,7 +36,7 @@ do_deploy:append:k3r5 () {
j=$(expr $j + 1);
if [ $j -eq $i ]
then
- if [ "${type}" = "dfu" ]; then
+ if [ "${type}" = "${UBOOT_DFU_CONFIG}" ]; then
TARGETSUFFIX="-dfu"
else
TARGETSUFFIX=""