summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-06-30 13:52:07 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-07-25 17:21:41 +0200
commit4c40178f77339a38712b4d37fdc5ef188929cbf3 (patch)
tree75a2e354b698ad4945eef54c9db9f3d1e885e64b
parent9d76eab841cd8ae812adde0387eff043a2832971 (diff)
u-boot: updated to the toradex_ti-u-boot-2023.04 branch
- Update to the toradex_ti-u-boot-2023.04 branch, based on the ti-u-boot-2023.04. - This includes/requires the move to use binman to assemble the binaries used for boot. - With the change to binman the R5 SPL is now built from one OE machine only, not one machine per SoC flavour (GP, HS-FS, HS). - With binman we also change the name for the tiboot3* files to match the machine they are built form, not claiming to be the evm. E.g. tiboot3-am62x-hs-fs-verdin.bin. - With the binman and HS-FS we need to package the kernel also as a fitimage to prevent a build error in U-Boot, however we keep using Image.gz - Drop the '-staging' from the recipe name. Related-to: ELB-5238 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/verdin-am62-k3r5-hs-fs.conf24
-rw-r--r--conf/machine/verdin-am62-k3r5.conf (renamed from conf/machine/verdin-am62-k3r5-gp.conf)9
-rw-r--r--conf/machine/verdin-am62.conf30
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb (renamed from recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb)39
4 files changed, 52 insertions, 50 deletions
diff --git a/conf/machine/verdin-am62-k3r5-hs-fs.conf b/conf/machine/verdin-am62-k3r5-hs-fs.conf
deleted file mode 100644
index 8f8c8e4..0000000
--- a/conf/machine/verdin-am62-k3r5-hs-fs.conf
+++ /dev/null
@@ -1,24 +0,0 @@
-#@TYPE: Machine
-#@NAME: Toradex Verdin AM62 (R5F)
-#@DESCRIPTION: Machine configuration for Toradex Verdin AM62 SoM (R5F core)
-#@MAINTAINER: Max Krummenacher <max.krummenacher@toradex.com>
-
-MACHINE_NAME = "Verdin-AM62"
-
-require conf/machine/include/k3r5.inc
-SOC_FAMILY:append = ":k3r5-hs-fs"
-
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-ti-staging"
-PREFERRED_PROVIDER_u-boot = "u-boot-toradex-ti-staging"
-
-SYSFW_SOC = "am62x"
-SYSFW_CONFIG = "evm"
-SYSFW_SUFFIX = "hs-fs"
-SYSFW_PREFIX:k3r5 = "fs"
-
-SYSFW_TIBOOT3_SYMLINK = ""
-
-UBOOT_DFU_CONFIG = "dfu-hs-fs"
-UBOOT_CONFIG ??= "dfu-hs-fs sd-hs-fs"
-UBOOT_CONFIG[dfu-hs-fs] = "verdin-am62_r5_usbdfu_defconfig,dfu,spl/u-boot-spl.bin"
-UBOOT_CONFIG[sd-hs-fs] = "verdin-am62_r5_defconfig,sdcard,spl/u-boot-spl.bin"
diff --git a/conf/machine/verdin-am62-k3r5-gp.conf b/conf/machine/verdin-am62-k3r5.conf
index 79bcdeb..ad5ab6d 100644
--- a/conf/machine/verdin-am62-k3r5-gp.conf
+++ b/conf/machine/verdin-am62-k3r5.conf
@@ -7,15 +7,12 @@ MACHINE_NAME = "Verdin-AM62"
require conf/machine/include/k3r5.inc
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-ti-staging"
-PREFERRED_PROVIDER_u-boot = "u-boot-toradex-ti-staging"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-ti"
+PREFERRED_PROVIDER_u-boot = "u-boot-toradex-ti"
SYSFW_SOC = "am62x"
-SYSFW_CONFIG = "evm"
+SYSFW_CONFIG = "verdin"
SYSFW_SUFFIX = "gp"
-SYSFW_PREFIX:k3r5 = "fs"
-
-SYSFW_TIBOOT3_SYMLINK = "tiboot3-gp.bin"
UBOOT_DFU_CONFIG = "dfu-gp"
UBOOT_CONFIG ??= "dfu-gp sd-gp"
diff --git a/conf/machine/verdin-am62.conf b/conf/machine/verdin-am62.conf
index e36adeb..75abfe5 100644
--- a/conf/machine/verdin-am62.conf
+++ b/conf/machine/verdin-am62.conf
@@ -9,11 +9,11 @@ MACHINE_FEATURES:remove = "efi"
require conf/machine/verdin-am62.inc
require conf/machine/include/am62xx.inc
-# override what am62xx.inc sets for a hs-fs/hs-se variant so that only
-# the gp variant is built and deployed and is the default.
-BBMULTICONFIG:remove = "k3r5-hs-se"
-do_image_complete[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy mc::k3r5-gp:ti-sci-fw:do_deploy"
-IMAGE_BOOT_FILES:remove = "tiboot3-am62x-hs-evm.bin"
+do_image[mcdepends] = "mc::k3r5:virtual/bootloader:do_deploy"
+
+# cope with our changed tiboot3 file names vs. the hardcoded TI AM625 SK-EVM ones
+IMAGE_BOOT_FILES:remove = "tiboot3-am62x-gp-evm.bin tiboot3-am62x-hs-evm.bin tiboot3-am62x-hs-fs-evm.bin"
+IMAGE_BOOT_FILES:append = " tiboot3-am62x-gp-verdin.bin tiboot3-am62x-hs-fs-verdin.bin tiboot3-am62x-hs-verdin.bin"
# Don't include kernels in standard images
RRECOMMENDS:${KERNEL_PACKAGE_NAME}-base = ""
@@ -22,8 +22,8 @@ MACHINE_EXTRA_RRECOMMENDS:append:am62xx = " kernel-modules"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex-ti"
PREFERRED_PROVIDER_virtual/dtb = "device-tree-overlays-ti"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-ti-staging"
-PREFERRED_PROVIDER_u-boot = "u-boot-toradex-ti-staging"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-ti"
+PREFERRED_PROVIDER_u-boot = "u-boot-toradex-ti"
KERNEL_DTB_PREFIX = "ti/"
KERNEL_DEVICETREE = " \
@@ -36,7 +36,7 @@ KERNEL_DEVICETREE = " \
"
KERNEL_IMAGETYPE = "Image.gz"
-KERNEL_IMAGETYPES = "Image Image.gz"
+KERNEL_IMAGETYPES = "fitImage Image Image.gz"
# overlays applied by generated overlays.txt
TEZI_EXTERNAL_KERNEL_DEVICETREE_BOOT = "verdin-am62_dsi-to-hdmi_overlay.dtbo verdin-am62_spidev_overlay.dtbo"
@@ -67,13 +67,13 @@ IMAGE_FSTYPES:append = " teziimg"
# The payload offsets are given in number of 512 byte blocks.
# tiboot3.bin
OFFSET_BOOTROM_PAYLOAD = "0"
-TPL_BINARY[0069] = "tiboot3-am62x-gp-evm.bin"
-TPL_BINARY[0071] = "tiboot3-am62x-gp-evm.bin"
-TPL_BINARY[0072] = "tiboot3-am62x-gp-evm.bin"
-TPL_BINARY[0073] = "tiboot3-am62x-hs-fs-evm.bin"
-TPL_BINARY[0074] = "tiboot3-am62x-hs-fs-evm.bin"
-TPL_BINARY[0075] = "tiboot3-am62x-hs-fs-evm.bin"
-TPL_BINARY[0076] = "tiboot3-am62x-hs-fs-evm.bin"
+TPL_BINARY[0069] = "tiboot3-am62x-gp-verdin.bin"
+TPL_BINARY[0071] = "tiboot3-am62x-gp-verdin.bin"
+TPL_BINARY[0072] = "tiboot3-am62x-gp-verdin.bin"
+TPL_BINARY[0073] = "tiboot3-am62x-hs-fs-verdin.bin"
+TPL_BINARY[0074] = "tiboot3-am62x-hs-fs-verdin.bin"
+TPL_BINARY[0075] = "tiboot3-am62x-hs-fs-verdin.bin"
+TPL_BINARY[0076] = "tiboot3-am62x-hs-fs-verdin.bin"
# tispl.bin
OFFSET_TPL_PAYLOAD = "1024"
# u-boot.img
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 6cdca41..a5a9ce0 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -5,15 +5,13 @@ LICENSE = "GPL-2.0-or-later"
require recipes-bsp/u-boot/u-boot-ti.inc
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
-
-DEPENDS += "flex-native bison-native"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "1758570639a6bd53e968808a624db532ad905c4b"
+SRCREV = "2ddf78e50e65686b8d14e76908d534ef66b9f83d"
SRCREV:use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_ti-u-boot-2021.01_bringup"
+SRCBRANCH = "toradex_ti-u-boot-2023.04"
B = "${WORKDIR}/build"
S = "${WORKDIR}/git"
@@ -32,6 +30,37 @@ DEPLOY_INITIAL_ENV:k3r5 = ":"
do_deploy:append () {
${DEPLOY_INITIAL_ENV}
}
+do_deploy:append:k3r5 () {
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]
+ then
+ for f in ${B}/${config}/tiboot3-*.bin; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+
+ for f in ${B}/${config}/sysfw*.itb; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+ fi
+ done
+ unset j
+ done
+ unset i
+ else
+ if ! [ -f ${B}/${UBOOT_BINARY} ]; then
+ ln -s spl/${UBOOT_BINARY} ${B}/${UBOOT_BINARY}
+ fi
+ fi
+}
# build the k3r5 spl also for DFU
do_compile:append:k3r5 () {