summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-02-24 12:04:07 +0100
committerMing Liu <ming.liu@toradex.com>2022-02-24 12:28:23 +0100
commit9400ee43d6b14fbea12a82a047056c8581ec9d70 (patch)
tree526351f46589c7e510489f84cf3a8eaa943b89ca /recipes-core
parentf79527a354485b85820e2b37807522b545d8863a (diff)
meta: use tdx overrides for Toradex specific changes
Toradex NXP layer could be used by other external projects, so we should make sure Toradex specific changes dont impact them. Use 'tdx' overrides to ensure Toradex specific changes only valid for Toradex distros. Related-to: ELB-3046 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/systemd/systemd-conf_%.bbappend2
-rw-r--r--recipes-core/systemd/systemd_%.bbappend4
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend6
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-core/systemd/systemd-conf_%.bbappend b/recipes-core/systemd/systemd-conf_%.bbappend
index 77ab59d..0c4792c 100644
--- a/recipes-core/systemd/systemd-conf_%.bbappend
+++ b/recipes-core/systemd/systemd-conf_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-conf:"
+FILESEXTRAPATHS_prepend_tdx := "${THISDIR}/systemd-conf:"
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index ea40849..ec30022 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,4 @@
# This allows for udevd automounting with mounts accessible to all.
-do_configure_prepend () {
+do_configure_prepend_tdx () {
sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
-} \ No newline at end of file
+}
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index 7b03d77..49a930b 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,10 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
-SRC_URI_append = " file://hotplug.rules \
- file://hotplug.sh \
+SRC_URI_append_tdx = " file://hotplug.rules \
+ file://hotplug.sh \
"
-do_install_append() {
+do_install_append_tdx () {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/hotplug.rules ${D}${sysconfdir}/udev/rules.d/hotplug.rules