summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-10-12 07:55:31 +0200
committerMing Liu <ming.liu@toradex.int>2020-10-16 15:15:28 +0000
commit7b7a2f85e2fcea83c15b1819479506d7d18914bc (patch)
tree9e693d9eb9cd413945343c708a41959aa0e32921 /recipes-bsp
parent0006e2a7616674e768a698123a13caff5c1661ba (diff)
u-boot-distro-boot: dont inherit nopackages
The reason we inherit nopackages was that there was no files being packaged at that moment, but this makes it impossible for a bbappend to add packages, let's drop it. Now torizoncore decides to add a ostree-uboot-env package in this recipe. Related-to: TOR-1335 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 8010ac7..596d6df 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -12,7 +12,7 @@ SRC_URI = " \
KERNEL_BOOTCMD ??= "bootz"
KERNEL_BOOTCMD_aarch64 ?= "booti"
-inherit deploy nopackages
+inherit deploy
do_deploy() {
sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/;s/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \