summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/files/fw_unlock_mmc.sh6
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb8
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/files/fw_unlock_mmc.sh b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
new file mode 100644
index 0000000..8982640
--- /dev/null
+++ b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
@@ -0,0 +1,6 @@
+# Give fw_setenv mmcblk0boot1 write permissions
+function fw_setenv() {
+ echo 0 > /sys/block/mmcblk0boot1/force_ro
+ /sbin/fw_setenv "$@"
+ echo 1 > /sys/block/mmcblk0boot1/force_ro
+}
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 4226958..029fc92 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -14,7 +14,8 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex"
-SRC_URI += "file://fw_env.config"
+SRC_URI += "file://fw_env.config \
+ file://fw_unlock_mmc.sh"
# This revision is based on upstream "v2015.04"
SRCREV = "06ee8db6422e02337242e43b8573359443db59ea"
@@ -44,6 +45,11 @@ do_install () {
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
+do_install_append_tegra3() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
pkg_postinst_${PN}_colibri-t20 () {
# can't do this offline
if [ "x$D" != "x" ]; then