summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb19
-rw-r--r--recipes/images/trdx-extra.inc1
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
new file mode 100644
index 0000000..0b778d6
--- /dev/null
+++ b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Disable LVDS output in favour of primary HDMI one on Apalis TK1"
+LICENSE = "PD"
+
+SRC_URI = " \
+ file://COPYING \
+"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
+ echo "${bindir}/xrandr --output LVDS-0 --off" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
+}
+
+pkg_postrm_${PN}() {
+ sed -i /xrandr.*output.*LVDS.*off/d ${sysconfdir}/xdg/lxsession/LXDE/autostart || true
+}
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index 3c38e4b..607c58f 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -48,6 +48,7 @@ IMAGE_INSTALL_append_tegra124 = " \
file \
fs-init \
kernel-modules \
+ lvds-tegra124 \
pciutils \
ptpd \
tegrastats \