summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-08-15 18:11:34 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-08-15 18:11:34 +0200
commit9618437052db27491d9628be818c0e6709dcf9b3 (patch)
treebf77dc68992172df6ec039a57ec4a1cd0db93da0 /recipes
parent27856e71c4133815a4797ae5d84f14d57f820926 (diff)
L4T R15, oe-core Image V2.0Beta1
Diffstat (limited to 'recipes')
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend5
-rw-r--r--recipes/images/angstrom-lxde-image.bb31
-rw-r--r--recipes/images/console-trdx-image.bb11
-rw-r--r--recipes/images/files/burnflash.tar.bz2bin0 -> 2785280 bytes
-rw-r--r--recipes/images/trdx-extra.inc1
-rw-r--r--recipes/images/trdx-image-fstype.inc26
-rw-r--r--recipes/trdx-nv-binaries/files/colibri-t20/base.tgzbin6819545 -> 8084205 bytes
-rw-r--r--recipes/trdx-nv-binaries/files/colibri-t20/nvgstapps.tgzbin101084 -> 122495 bytes
-rw-r--r--recipes/trdx-nv-binaries/files/colibri-t20/restricted_codecs.tbz2bin346046 -> 346880 bytes
-rw-r--r--recipes/trdx-nv-binaries/files/nvsamples-oe.patch51
-rw-r--r--recipes/trdx-nv-binaries/nvsamples.bb47
-rw-r--r--recipes/trdx-nv-binaries/trdx-nv-binaries.bb3
-rw-r--r--recipes/xorg-xserver/files/crash-hack.patch11
-rw-r--r--recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend6
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend4
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend4
16 files changed, 179 insertions, 21 deletions
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index ca35824..6772d6b 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,4 +1,3 @@
-PRINC = "3"
+PRINC = "4"
-THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
-FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index f875074..fc936db 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -4,7 +4,11 @@ DESCRIPTION = "Image based on the LXDE desktop"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r1"
+PV = "V2.0"
+PR = "r3"
+
+#create the deployment directory-tree
+require trdx-image-fstype.inc
#create the file /etc/timestamp
IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
@@ -18,19 +22,19 @@ IMAGE_LINGUAS = "en-us"
#MAYBE WE WILL NEED THESE ALSO:
# xorg-minimal-fonts xserver-xorg-multimedia-modules xserver-xorg-utils
-IMAGE_SPLASH = "psplash-angstrom"
-PREFERRED_PROVIDER_psplash-support = "psplash-angstrom"
-PREFERRED_PROVIDER_virtual/psplash = "psplash-angstrom"
-
DISTRO_UPDATE_ALTERNATIVES ??= ""
ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-CONMANPKGS = ""
-#CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd connman-gnome"
+#CONMANPKGS = ""
+CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd connman-gnome"
CONMANPKGS_libc-uclibc = ""
DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
+#deploy the OpenGL ES headers to the sysroot
+DEPENDS += "nvsamples"
+
+
# Additional X libs not pulled in by any package \
# xtrans libxevie \
@@ -68,8 +72,10 @@ zeroconf \
IMAGE_INSTALL += " \
${IMAGE_INSTALL_CLASSIC} \
+ virtual-psplash \
angstrom-task-boot \
task-basic \
+ udev-extra-rules \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
@@ -86,7 +92,6 @@ IMAGE_INSTALL += " \
xhost \
xset \
\
- ${IMAGE_SPLASH} \
${XSERVER} \
xrandr \
xrdb \
@@ -113,6 +118,7 @@ IMAGE_INSTALL += " \
gst-plugins-base-theora \
gst-plugins-base-videotestsrc \
gst-plugins-base-vorbis \
+ gst-plugins-good-isomp4 \
gst-plugins-good-matroska \
gst-plugins-good-rtp \
gst-plugins-good-udp \
@@ -121,12 +127,15 @@ IMAGE_INSTALL += " \
gst-plugins-good-wavparse \
gst-plugins-ugly-asf \
libpcre \
+ libpcreposix \
libxcomposite \
- firefox \
- flash-plugins \
+ alsa-states \
"
-# gst-plugin-qtdemux
+# firefox at the moment segfaults
+# firefox \
+# flash-plugins \
+
# gst-plugin-mpegdemux
require lx.inc
diff --git a/recipes/images/console-trdx-image.bb b/recipes/images/console-trdx-image.bb
index 5531579..5425dc9 100644
--- a/recipes/images/console-trdx-image.bb
+++ b/recipes/images/console-trdx-image.bb
@@ -4,11 +4,17 @@ DESCRIPTION = "Image booting to a console"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+PV = "ConsoleV2.0"
+PR = "r3"
+
+#create the deployment directory-tree
+require trdx-image-fstype.inc
+
#create the file /etc/timestamp
IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
#IMAGE_LINGUAS = ""
-#IMAGE_LINGUAS = "en-us"
+IMAGE_LINGUAS = "en-us"
#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
@@ -17,7 +23,8 @@ ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",
DISTRO_UPDATE_ALTERNATIVES ??= ""
ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
+CONMANPKGS = ""
+#CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd connman-gnome"
CONMANPKGS_libc-uclibc = ""
diff --git a/recipes/images/files/burnflash.tar.bz2 b/recipes/images/files/burnflash.tar.bz2
new file mode 100644
index 0000000..8d0c33b
--- /dev/null
+++ b/recipes/images/files/burnflash.tar.bz2
Binary files differ
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index ed0c367..6058ffc 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -29,6 +29,7 @@ IMAGE_INSTALL += " \
joe \
minicom \
ldd \
+ lsof \
mtd-utils \
update-modules \
\
diff --git a/recipes/images/trdx-image-fstype.inc b/recipes/images/trdx-image-fstype.inc
new file mode 100644
index 0000000..2ffb8f4
--- /dev/null
+++ b/recipes/images/trdx-image-fstype.inc
@@ -0,0 +1,26 @@
+#create the deployment directory-tree
+
+BURNFLASH := "${THISDIR}/files/burnflash.tar.bz2"
+S = "${WORKDIR}/burnflash"
+IMAGE_ROOTFS = "${WORKDIR}/T20_LinuxImage${PV}/rootfs"
+
+do_rootfs_prepend() {
+ tar -C ${WORKDIR} -xf ${BURNFLASH}
+ mkdir -p ${IMAGE_ROOTFS}
+ cp -pPr ${S}/* ${IMAGE_ROOTFS}/../
+}
+
+do_rootfs_append() {
+ # put u-boot, kernel into the bin directories, remove the kernel from the rootfs/boot
+ rm ${IMAGE_ROOTFS}/boot/uImage*
+ cp -pP ${DEPLOY_DIR_IMAGE}/uImage* ${IMAGE_ROOTFS}/../bin/
+ mv ${IMAGE_ROOTFS}/../bin/uImage-${MACHINE}.bin ${IMAGE_ROOTFS}/../bin/uImage
+
+ cp -pP ${DEPLOY_DIR_IMAGE}/u-boot* ${IMAGE_ROOTFS}/../bin/
+ rm ${IMAGE_ROOTFS}/../bin/u-boot-hsmmc-${MACHINE}.bin
+ mv ${IMAGE_ROOTFS}/../bin/u-boot-${MACHINE}.bin ${IMAGE_ROOTFS}/../bin/u-boot.bin
+
+ #create tarball
+ DATE=`date +%Y%m%d`
+ cd ${WORKDIR}; tar -cjvf ${DEPLOY_DIR_IMAGE}/T20_LinuxImage${PV}_${DATE}.tar.bz2 T20_LinuxImage${PV}
+}
diff --git a/recipes/trdx-nv-binaries/files/colibri-t20/base.tgz b/recipes/trdx-nv-binaries/files/colibri-t20/base.tgz
index 11b1595..44190ce 100644
--- a/recipes/trdx-nv-binaries/files/colibri-t20/base.tgz
+++ b/recipes/trdx-nv-binaries/files/colibri-t20/base.tgz
Binary files differ
diff --git a/recipes/trdx-nv-binaries/files/colibri-t20/nvgstapps.tgz b/recipes/trdx-nv-binaries/files/colibri-t20/nvgstapps.tgz
index 7492c0e..3ee91d4 100644
--- a/recipes/trdx-nv-binaries/files/colibri-t20/nvgstapps.tgz
+++ b/recipes/trdx-nv-binaries/files/colibri-t20/nvgstapps.tgz
Binary files differ
diff --git a/recipes/trdx-nv-binaries/files/colibri-t20/restricted_codecs.tbz2 b/recipes/trdx-nv-binaries/files/colibri-t20/restricted_codecs.tbz2
index 6647b2d..ed6c9f4 100644
--- a/recipes/trdx-nv-binaries/files/colibri-t20/restricted_codecs.tbz2
+++ b/recipes/trdx-nv-binaries/files/colibri-t20/restricted_codecs.tbz2
Binary files differ
diff --git a/recipes/trdx-nv-binaries/files/nvsamples-oe.patch b/recipes/trdx-nv-binaries/files/nvsamples-oe.patch
new file mode 100644
index 0000000..001c162
--- /dev/null
+++ b/recipes/trdx-nv-binaries/files/nvsamples-oe.patch
@@ -0,0 +1,51 @@
+diff -Naur nvsamples-1.0-r0.orig/nvsamples/make/nvdefs.mk nvsamples-1.0-r0/nvsamples/make/nvdefs.mk
+--- nvsamples/make/nvdefs.mk.orig 2011-12-07 10:22:49.000000000 +0100
++++ nvsamples/make/nvdefs.mk 2012-07-07 12:37:13.000000000 +0200
+@@ -1,4 +1,4 @@
+-NV_TOPDIR = $(HOME)/nvsamples
++NV_TOPDIR = $(WORKDIR)/nvsamples
+ NV_PLATFORM_DIR = $(NV_TOPDIR)
+ NV_KERNDIR = $(NV_TOPDIR)/../kernel
+
+@@ -42,17 +42,13 @@
+ NV_PLATFORM_CPPFLAGS += -DKD
+ endif
+
+-NV_PLATFORM_LDFLAGS =
++NV_PLATFORM_LDFLAGS = -L/usr/X11R6.4/lib -lX11 -lICE -lSM
+
+ NV_PLATFORM_SDK_INC_DIR = $(NV_TOPDIR)/include
+ NV_PLATFORM_SDK_LIB_DIR = $(NV_TOPDIR)/lib-target
+-ROOTFS_LIB_DIR = $(NV_TOPDIR)/../T20_LinuxImageV1.0Beta4/rootfs/usr/lib
+
+ NV_PLATFORM_SDK_INC = -I$(NV_PLATFORM_SDK_INC_DIR)
+-NV_PLATFORM_SDK_LIB = -L$(NV_PLATFORM_SDK_LIB_DIR) \
+- -L$(ROOTFS_LIB_DIR) \
+- -Xlinker -rpath-link \
+- -Xlinker $(ROOTFS_LIB_DIR)
++NV_PLATFORM_SDK_LIB = -L$(NV_PLATFORM_SDK_LIB_DIR)
+ NV_PLATFORM_OPT = -Os -O2
+ NV_PLATFORM_MATHLIB = -lm
+ NV_PLATFORM_THREADLIB = -lpthread
+@@ -80,13 +76,13 @@
+
+ # compiler utilities
+
+-CROSSBIN = $(NV_TOPDIR)/../arm-2009q3/bin/arm-none-linux-gnueabi-
+-CC = $(CROSSBIN)gcc
+-CXX = $(CROSSBIN)g++
+-LD = $(CROSSBIN)gcc
+-AR = $(CROSSBIN)ar
+-RANLIB = $(CROSSBIN)ranlib
+-STRIP = $(CROSSBIN)strip
++CROSSBIN = arm-angstrom-linux-gnueabi-
++CC ?= $(CROSSBIN)gcc
++CXX ?= $(CROSSBIN)g++
++LD = $(CC)
++AR ?= $(CROSSBIN)ar
++RANLIB ?= $(CROSSBIN)ranlib
++STRIP ?= $(CROSSBIN)strip
+
+ NV_CGDIR = $(NV_TOPDIR)/utils/Cg
+ HEXIFY = $(NV_CGDIR)/hexify.pl
+Datei nvsamples-1.0-r0.orig/pseudo/pseudo.socket ist ein socket wÀhrend Datei nvsamples-1.0-r0/pseudo/pseudo.socket ein socket ist.
diff --git a/recipes/trdx-nv-binaries/nvsamples.bb b/recipes/trdx-nv-binaries/nvsamples.bb
new file mode 100644
index 0000000..d24b82e
--- /dev/null
+++ b/recipes/trdx-nv-binaries/nvsamples.bb
@@ -0,0 +1,47 @@
+SECTION = "graphical/utils"
+DESCRIPTION = "Nvidia samples for OpenGL ES, OpenGL ES headers"
+LICENSE = "CLOSED"
+DEPENDS = "trdx-nv-binaries"
+RDEPENDS = "trdx-nv-binaries"
+
+PR = "r0"
+
+SRC_URI = "http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Samples/nvsamples.tar.bz2 \
+ file://nvsamples-oe.patch \
+"
+
+S = "${WORKDIR}/nvsamples"
+
+SRC_URI[md5sum] = "240b0beb0056dde2e6ac1538dc8b6684"
+SRC_URI[sha256sum] = "2638beea80fd85fdc5f9443e6959c210e275e627f662266cd404ce7c68b0806d"
+
+#no gnu_hash in NVIDIA binaries, skip QA for this package
+INSANE_SKIP_${PN} = "dev-so ldflags"
+
+FILES_${PN} += " \
+ /home/root/textures/* \
+"
+
+do_compile () {
+ cd ${S}/samples/opengles2
+ oe_runmake clean
+ oe_runmake WORKDIR=${WORKDIR}
+}
+
+do_install () {
+# install the sample code
+ install -d ${D}${bindir}
+ install -d ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/ctree/ctree ${D}${bindir}
+ install -m 0644 ${S}/samples/opengles2/ctree/textures/* ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/bubble/bubble ${D}${bindir}
+ install -m 0644 ${S}/samples/opengles2/bubble/textures/* ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/gears/gears ${D}${bindir}
+
+# export OpenGL ES headers
+ for dir in EGL GLES2 KD KHR OpenMAX/il OpenMAX/ilclient
+ do
+ install -d ${D}${includedir}/$dir
+ install -m 0644 ${S}/include/$dir/* ${D}${includedir}/$dir
+ done
+} \ No newline at end of file
diff --git a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
index a9aa513..ee9c8e1 100644
--- a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
+++ b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "binary files from Nvidia along with there configuration"
LICENSE = "CLOSED"
-PR = "r3"
+PR = "r4"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -49,6 +49,7 @@ do_install_colibri-t20 () {
install -m 0644 ${WORKDIR}/mimeapps.list ${D}//home/root/.local/share/applications/
install -m 0644 ${WORKDIR}/nvgstplayer.desktop ${D}/home/root/.local/share/applications/
ln -s libpcre.so.0.0.1 ${D}/usr/lib/libpcre.so.3
+ ln -s libpcreposix.so.0.0.0 ${D}/usr/lib/libpcreposix.so.3
ln -s tegra_drv.abi11.so ${D}/usr/lib/xorg/modules/drivers/tegra_drv.so
ln -s libGLESv2.so ${D}/usr/lib//libGLESv2.so.2
ln -s libEGL.so ${D}/usr/lib/libEGL.so.1
diff --git a/recipes/xorg-xserver/files/crash-hack.patch b/recipes/xorg-xserver/files/crash-hack.patch
new file mode 100644
index 0000000..0053a10
--- /dev/null
+++ b/recipes/xorg-xserver/files/crash-hack.patch
@@ -0,0 +1,11 @@
+--- xorg-server-1.11.2/miext/damage/damage.c~ 2011-04-24 06:54:03.000000000 +0200
++++ xorg-server-1.11.2/miext/damage/damage.c 2012-07-27 12:12:00.012473812 +0200
+@@ -596,6 +596,8 @@
+ ScreenPtr pScreen = pDst->pDrawable->pScreen;
+ PictureScreenPtr ps = GetPictureScreen(pScreen);
+ damageScrPriv(pScreen);
++ //ugly hack, the xserver crashes when gtk programs use some fancy font rendering, this prevents this
++ maskFormat = 0;
+
+ if (checkPictureDamage (pDst))
+ {
diff --git a/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 1615df3..883a3c2 100644
--- a/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1,5 +1,3 @@
-PRINC = "2"
-
-THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
-FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+PRINC = "3"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend b/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend
new file mode 100644
index 0000000..77e6079
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend
@@ -0,0 +1,4 @@
+# Ugly temporary hack to have Xserver not segfaulting
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://xserver-instrumented.patch;pnum=2"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..44ae424
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,4 @@
+# Ugly temporary hack to have Xserver not segfaulting
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://crash-hack.patch"