summaryrefslogtreecommitdiff
path: root/recipes-connectivity/openssl/openssl/Makefiles-ptest.patch
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-06 09:56:43 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-06 09:56:43 +0200
commit2c7ba109910c171acea3561746f8ee37dc6de361 (patch)
treea8f614f8c5799c4fac43dccd3988eb787fd6d4a0 /recipes-connectivity/openssl/openssl/Makefiles-ptest.patch
parent947ffa0680228c52c6aed322a84ad451e1c140c1 (diff)
openssl: update 1.0.2d -> 1.0.2k
This is basically a back port of the following commits from the openembedded-core master branch: openssl: actually apply Use-SHA256-not-MD5-as-default-digest.patch openssl: Fix symlink creation openssl: Updgrade 1.0.2j -> 1.0.2k openssl: Use linux-aarch64 target for aarch64 openssl-native: Compile with -fPIC openssl: Security fix CVE-2016-7055 OpenSSL: CVE-2004-2761 replace MD5 hash algorithm openssl: fix bashism in c_rehash shell script openssl: rehash actual mozilla certificates inside rootfs openssl: Upgrade 1.0.2i -> 1.0.2j openssl.inc: avoid random ptest failures openssl: update to 1.0.2i (CVE-2016-6304 and more) openssl: fix do_configure error when cwd is not in @INC openssl: fix add missing dependencies building for test directory openssl: Security fix CVE-2016-2178 openssl: Security fix CVE-2016-2177 openssl: prevent warnings from openssl-c_rehash.sh openssl: fix the dangling libcrypto.a symlink openssl: Ensure SSL certificates are stored on sysconfdir openssl: Add Shell-Script based c_rehash utility openssl: Security fix via update to 1.0.2h openssl.inc: minor packaging cleanup openssl: don't move libcrypto to base_libdir openssl: add a patch to fix parallel builds openssl: Security fix Drown via 1.0.2g update openssl.inc: drop obsolete mtx-1 and mtx-2 over-rides openssl: Explicitly set EXTRA_OEMAKE as required openssl: update 1.0.2e -> 1.0.2f ( CVE-2016-0701 CVE-2015-3197 ) openssl: Add musl configuration support openssl: update to 1.0.2e openssl: enable parallel make openssl: fix ptest issues openssl: use subdir= instead of moving files in do_configure_prepend() openssl: sanity check that the bignum module is present openssl: fix ptest failures Note that this requires a complete image rebuild due to ABI breakage. If that is not desired something along those lines would need to be integrated as well: http://cgit.openembedded.org/openembedded-core/commit?id=480db6be99f9a53d8657b31b846f0079ee1a124f Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-connectivity/openssl/openssl/Makefiles-ptest.patch')
-rw-r--r--recipes-connectivity/openssl/openssl/Makefiles-ptest.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl/Makefiles-ptest.patch b/recipes-connectivity/openssl/openssl/Makefiles-ptest.patch
new file mode 100644
index 0000000..249446a
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl/Makefiles-ptest.patch
@@ -0,0 +1,77 @@
+Add 'buildtest' and 'runtest' targets to Makefile, to build and run tests
+cross-compiled.
+
+Signed-off-by: Anders Roxell <anders.roxell@enea.com>
+Signed-off-by: Maxin B. John <maxin.john@enea.com>
+Upstream-Status: Pending
+---
+Index: openssl-1.0.2/Makefile.org
+===================================================================
+--- openssl-1.0.2.orig/Makefile.org
++++ openssl-1.0.2/Makefile.org
+@@ -451,8 +451,16 @@ rehash.time: certs apps
+ test: tests
+
+ tests: rehash
++ $(MAKE) buildtest
++ $(MAKE) runtest
++
++buildtest:
++ @(cd test && \
++ $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf exe apps);
++
++runtest:
+ @(cd test && echo "testing..." && \
+- $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf tests );
++ $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf alltests );
+ OPENSSL_CONF=apps/openssl.cnf util/opensslwrap.sh version -a
+
+ report:
+Index: openssl-1.0.2/test/Makefile
+===================================================================
+--- openssl-1.0.2.orig/test/Makefile
++++ openssl-1.0.2/test/Makefile
+@@ -137,7 +137,7 @@ tests: exe apps $(TESTS)
+ apps:
+ @(cd ..; $(MAKE) DIRS=apps all)
+
+-alltests: \
++all-tests= \
+ test_des test_idea test_sha test_md4 test_md5 test_hmac \
+ test_md2 test_mdc2 test_wp \
+ test_rmd test_rc2 test_rc4 test_rc5 test_bf test_cast test_aes \
+@@ -148,6 +148,11 @@ alltests: \
+ test_jpake test_srp test_cms test_ocsp test_v3name test_heartbeat \
+ test_constant_time
+
++alltests:
++ @(for i in $(all-tests); do \
++ ( $(MAKE) $$i && echo "PASS: $$i" ) || echo "FAIL: $$i"; \
++ done)
++
+ test_evp: $(EVPTEST)$(EXE_EXT) evptests.txt
+ ../util/shlib_wrap.sh ./$(EVPTEST) evptests.txt
+
+@@ -213,7 +218,7 @@ test_x509: ../apps/openssl$(EXE_EXT) tx5
+ echo test second x509v3 certificate
+ sh ./tx509 v3-cert2.pem 2>/dev/null
+
+-test_rsa: $(RSATEST)$(EXE_EXT) ../apps/openssl$(EXE_EXT) trsa testrsa.pem
++test_rsa: ../apps/openssl$(EXE_EXT) trsa testrsa.pem
+ @sh ./trsa 2>/dev/null
+ ../util/shlib_wrap.sh ./$(RSATEST)
+
+@@ -313,11 +318,11 @@ test_tsa: ../apps/openssl$(EXE_EXT) test
+ sh ./testtsa; \
+ fi
+
+-test_ige: $(IGETEST)$(EXE_EXT)
++test_ige:
+ @echo "Test IGE mode"
+ ../util/shlib_wrap.sh ./$(IGETEST)
+
+-test_jpake: $(JPAKETEST)$(EXE_EXT)
++test_jpake:
+ @echo "Test JPAKE"
+ ../util/shlib_wrap.sh ./$(JPAKETEST)
+