summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-03-29 16:16:29 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-03-30 19:57:41 +0200
commitd4d762e880a69c415b546575c2d736ea4992838d (patch)
tree29c63af352bc68ea3a7e8930bdf6bc4f99acfe6a
parent966b60241cba76bacb343a39a0b188707b8c37d4 (diff)
overrides: use append instead of +=
We want to append to the generic VAR when we build for a tegra machine. Using VAR_tegra += "" creates a machine specific VAR. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/eglinfo/eglinfo-x11_%.bbappend2
-rw-r--r--recipes/images/angstrom-lxde-image.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
index f3eb4fd..c8b8985 100644
--- a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
+++ b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
# Set Tegra specific dependencies and device type
-DEPENDS_tegra += "virtual/libgles2"
+DEPENDS_append_tegra = " virtual/libgles2"
EGLINFO_DEVICE_tegra = "generic"
SRCREV = "223817ee37988042db7873cfb5b2e899dfe35c10"
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 68026a7..22a4859 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -43,7 +43,7 @@ ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none
CONMANPKGS ?= "connman connman-client connman-gnome"
CONMANPKGS_libc-uclibc = ""
-DEPENDS_tegra += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
+DEPENDS_append_tegra = " gst-plugins-good gst-plugins-bad gst-plugins-ugly"
#do not build plugins-ugly because it would require to whitelist LICENCES without deploying them
DEPENDS += "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"