summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-06-16 11:30:17 +0200
committerMax Krummenacher <max.oss.09@gmail.com>2015-10-12 15:15:40 +0200
commitc1534d3008ffc34ae590e9e80682bc22ee2f8c5c (patch)
treeded91b04854ed6912a3e73c9d82c24277583f1b6
parente10ff4d2f038729f8731556162aadf220a401bde (diff)
base-files/u-boot-toradex-fw-utils: move MMC unlock
The mmc unlock function causes troubles when using Poky reference distribution since Poky uses the busybox shell: /etc/rc5.d/S09xserver-nodm: /etc/profile.d/fw_unlock_mmc.sh: line 2: syntax error: unexpected "(" This avoids X getting at all. This patch does not solve the underlying problem, but works around it by moving the script to the u-boot-toradex-fw-utils recipe, which is not installed by the Poky images by default.
-rw-r--r--recipes-bsp/u-boot/files/fw_unlock_mmc.sh (renamed from recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh)0
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb8
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend7
3 files changed, 7 insertions, 8 deletions
diff --git a/recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
index 8982640..8982640 100644
--- a/recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh
+++ b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 4226958..029fc92 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -14,7 +14,8 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex"
-SRC_URI += "file://fw_env.config"
+SRC_URI += "file://fw_env.config \
+ file://fw_unlock_mmc.sh"
# This revision is based on upstream "v2015.04"
SRCREV = "06ee8db6422e02337242e43b8573359443db59ea"
@@ -44,6 +45,11 @@ do_install () {
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
+do_install_append_tegra3() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
pkg_postinst_${PN}_colibri-t20 () {
# can't do this offline
if [ "x$D" != "x" ]; then
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index f423488..af82436 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,14 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/base-files:"
-SRC_URI_append_tegra3 = "file://fw_unlock_mmc.sh"
-
do_install_append () {
echo "search colibri.net" > ${D}${sysconfdir}/resolv.conf
echo "nameserver 8.8.8.8" >> ${D}${sysconfdir}/resolv.conf
echo "nameserver 8.8.4.4" >> ${D}${sysconfdir}/resolv.conf
}
-
-do_install_append_tegra3() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
-}