summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb32
1 files changed, 24 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 749dd2b..7e23d16 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "896eec92715d7062963d92bedd7dc61d643df1ea"
+SRCREV = "3578760d50593e8b7372ae5e3f6422da2bd09b2e"
SRCREV:use-head-next = "${AUTOREV}"
SRCBRANCH = "toradex_ti-u-boot-2023.04"
@@ -23,14 +23,30 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-# preserve and deploy u-boot-initial-env if building for the Cortex-A53 core
-# even if u-boot-ti.inc do_deploy() tries to delete it.
-DEPLOY_INITIAL_ENV = "install -D -m 644 ${B}/sd/u-boot-initial-env ${DEPLOYDIR}/ || true"
-DEPLOY_INITIAL_ENV:k3r5 = ":"
-do_deploy:append () {
- ${DEPLOY_INITIAL_ENV}
+do_compile[mcdepends] += "mc::k3r5:virtual/bootloader:do_deploy"
+
+do_compile:prepend:k3 () {
+ cp ${DEPLOY_DIR_IMAGE}/tiboot3-*.bin ${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/
+}
+
+do_deploy:append:k3 () {
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ for f in ${B}/${config}/firmware-*.bin; do
+ if [ -f "$f" ]; then
+ install -m 644 $f ${DEPLOYDIR}/
+ fi
+ done
+ done
+ fi
}
+
do_deploy:append:k3r5 () {
+ # remove any u-boot-initial-env* file not already removed by the
+ # u-boot-ti.inc
+ rm -f ${DEPLOYDIR}/u-boot-initial-env*
+
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do
@@ -39,7 +55,7 @@ do_deploy:append:k3r5 () {
j=$(expr $j + 1);
if [ $j -eq $i ]
then
- if [ "${type}" = "dfu" ]; then
+ if [ "${type}" = "${UBOOT_DFU_CONFIG}" ]; then
TARGETSUFFIX="-dfu"
else
TARGETSUFFIX=""