summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-08 15:28:09 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-08 17:40:44 +0200
commit7b64c52cad283964691e6b1e0a1f1cea00bbc2d8 (patch)
treef58248cba1a00e25e0478f16293bd8d436eba490
parent61bac0ad64aeda8bf4cd47c4085fc3a5c575638e (diff)
u-boot-toradex-ti: stop deploying any k3r5 u-boot-inital-env files
We've seen builds were those made it into the final image instead of the once from the regular U-Boot. This made such an image unbootable. It is propbably caused by a race condition when the file and the symlinks get deployed. Last symlink creator wins. Related-to: ELB-5751 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index 83ed9a0..74ea005 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -24,6 +24,10 @@ COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_deploy:append:k3r5 () {
+ # remove any u-boot-initial-env* file not already removed by the
+ # u-boot-ti.inc
+ rm -f ${DEPLOYDIR}/u-boot-initial-env*
+
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do