summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-06 13:57:46 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-06 16:53:11 +0200
commit27e16c96a7579bb70ef589dd6e38970577d4dbce (patch)
tree2ab24c1b2803d4acc9915d2f152a4077494be0b0
parent98b06e1c7ee86731a26ef4016fad0b206c308b40 (diff)
u-boot-toradex-ti: change deployment of tiboot3 for dfu
Checking for the type rather than for the config name allows reuse for other k3 based SoC. Related-to: ELB-5482 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
index bfcd1c2..749dd2b 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti_2023.04.bb
@@ -34,17 +34,16 @@ do_deploy:append:k3r5 () {
if [ -n "${UBOOT_CONFIG}" ]
then
for config in ${UBOOT_MACHINE}; do
- if [ x${config} = "xverdin-am62_r5_usbdfu_defconfig" ]
- then
- TARGETSUFFIX="-dfu"
- else
- TARGETSUFFIX=""
- fi
i=$(expr $i + 1);
for type in ${UBOOT_CONFIG}; do
j=$(expr $j + 1);
if [ $j -eq $i ]
then
+ if [ "${type}" = "dfu" ]; then
+ TARGETSUFFIX="-dfu"
+ else
+ TARGETSUFFIX=""
+ fi
for f in ${B}/${config}/tiboot3-*.bin; do
if [ -f "$f" ]; then
TARGET=$(basename $f)${TARGETSUFFIX}