summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-01 18:03:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-06 16:53:11 +0200
commit0102362f4d1920fc625053f2248d45fd085b9448 (patch)
tree586f51ffdec4718e9afa83250ef7f272cda1d93d
parent202e142d68ce77e47aa355af2eee359a23fb5ca3 (diff)
recipes: generalize override from am62 to k3
Related-to: ELB-5482 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend34
-rw-r--r--qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend4
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend2
-rw-r--r--recipes-graphics/libepoxy/libepoxy_1.5.%.bbappend4
-rw-r--r--recipes-graphics/wayland/wayland-protocols_%.bbappend6
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend4
6 files changed, 27 insertions, 27 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 426640e..72bc506 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,13 +1,13 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-# am62xx extra gles2 packageconfig flags
-GLES_EXTRA_DEPS:am62xx = "libdrm wayland"
-# rename from gles2 to gles2extra to preserve the original one for non am62xx machines
+# TI k3 extra gles2 packageconfig flags
+GLES_EXTRA_DEPS:k3 = "libdrm wayland"
+# rename from gles2 to gles2extra to preserve the original one for non k3 machines
PACKAGECONFIG[gles2extra] = "-opengl es2 -eglfs,,virtual/libgles2 virtual/egl ${GLES_EXTRA_DEPS}"
-PR:append:am62xx = ".arago17"
+PR:append:k3 = ".arago17"
-QT_CONFIG_FLAGS:append:am62xx = " -qpa ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'eglfs', d)}"
+QT_CONFIG_FLAGS:append:k3 = " -qpa ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'eglfs', d)}"
QT_EGLFS_PATCHES = "\
file://0001-calculator-Add-exit-button-for-non-window-environmen.patch \
@@ -17,14 +17,14 @@ QT_EGLFS_PATCHES = "\
# file://0002-deform-disable-opengl-button.patch
-SRC_URI:append:am62xx = "\
+SRC_URI:append:k3 = "\
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', "${QT_EGLFS_PATCHES}", d)}\
file://0001-deform-Fix-how-controls-are-shown.patch \
file://0001-qtbase-plugins-platforms-eglfs_kms-fix-compiler-erro.patch \
file://0001-eglfs-Force-888-format-only-on-env-flag.patch \
"
-python do_patch:append:am62xx () {
+python do_patch:append:k3 () {
import shutil
work_dir = d.getVar("WORKDIR")
@@ -35,30 +35,30 @@ python do_patch:append:am62xx () {
}
# Add symbolic link qt5/examples for backward compatibility
-do_install:append:am62xx () {
+do_install:append:k3 () {
install -d ${D}${datadir}/qt5
ln -sf ../examples ${D}${datadir}/qt5/examples
}
-FILES:${PN}-examples:append:am62xx = " ${datadir}/qt5/*"
+FILES:${PN}-examples:append:k3 = " ${datadir}/qt5/*"
-RDEPENDS:${PN}:am62xx += "${PN}-conf"
+RDEPENDS:${PN}:k3 += "${PN}-conf"
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"
############################### TDX added
# from meta-arago/conf/layer.conf
-PACKAGECONFIG_GL:am62xx = "gles2extra linuxfb"
-PACKAGECONFIG_DISTRO:am62xx = "icu examples accessibility gif gbm kms libinput"
-PACKAGECONFIG_FONTS:am62xx = "fontconfig"
+PACKAGECONFIG_GL:k3 = "gles2extra linuxfb"
+PACKAGECONFIG_DISTRO:k3 = "icu examples accessibility gif gbm kms libinput"
+PACKAGECONFIG_FONTS:k3 = "fontconfig"
-PACKAGECONFIG:remove:am62xx = "kms"
-PACKAGECONFIG:remove:am62xx = "vulkan"
-PACKAGECONFIG:remove:am62xx = "glib xcb"
+PACKAGECONFIG:remove:k3 = "kms"
+PACKAGECONFIG:remove:k3 = "vulkan"
+PACKAGECONFIG:remove:k3 = "glib xcb"
# they don't apply without changes, drop them for now
SRC_URI:remove = " \
file://0002-deform-disable-opengl-button.patch \
diff --git a/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 7f3fa8f..1e5029c 100644
--- a/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1,2 +1,2 @@
-PACKAGECONFIG:remove:am62xx = "wayland-vulkan-server-buffer xcomposite-egl xcomposite-glx"
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGECONFIG:remove:k3 = "wayland-vulkan-server-buffer xcomposite-egl xcomposite-glx"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 4adffc0..b19b00a 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -1 +1 @@
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"
diff --git a/recipes-graphics/libepoxy/libepoxy_1.5.%.bbappend b/recipes-graphics/libepoxy/libepoxy_1.5.%.bbappend
index 755654b..bb9cb44 100644
--- a/recipes-graphics/libepoxy/libepoxy_1.5.%.bbappend
+++ b/recipes-graphics/libepoxy/libepoxy_1.5.%.bbappend
@@ -1,6 +1,6 @@
# Append EGL_CFLAGS to CFLAGS
-CFLAGS:append:am62xx = " \
+CFLAGS:append:k3 = " \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_API_FB', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '-DWL_EGL_PLATFORM', '', d)} \
"
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"
diff --git a/recipes-graphics/wayland/wayland-protocols_%.bbappend b/recipes-graphics/wayland/wayland-protocols_%.bbappend
index ef635ca..a497bdb 100644
--- a/recipes-graphics/wayland/wayland-protocols_%.bbappend
+++ b/recipes-graphics/wayland/wayland-protocols_%.bbappend
@@ -1,13 +1,13 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-PR:append:am62xx = ".arago2"
+PR:append:k3 = ".arago2"
-SRC_URI:append:am62xx = " \
+SRC_URI:append:k3 = " \
file://0001-wayland-drm-Add-wayland-drm-protocol-to-stable.patch \
file://0002-wayland-drm-Update-to-version-2.patch \
"
-do_install:append:am62xx () {
+do_install:append:k3 () {
install -d ${D}${datadir}/wayland-protocols/stable/wayland-drm
cp ${S}/stable/wayland-drm/wayland-drm.xml ${D}${datadir}/wayland-protocols/stable/wayland-drm/
}
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index 137b263..5e05c0a 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -1,2 +1,2 @@
-PACKAGECONFIG:remove:am62xx = "glamor glx"
-PACKAGE_ARCH:am62xx = "${MACHINE_ARCH}"
+PACKAGECONFIG:remove:k3 = "glamor glx"
+PACKAGE_ARCH:k3 = "${MACHINE_ARCH}"