summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex_3.10.40.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-toradex_3.10.40.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex_3.10.40.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-toradex_3.10.40.bb b/recipes-kernel/linux/linux-toradex_3.10.40.bb
index db18ea6..9c9467d 100644
--- a/recipes-kernel/linux/linux-toradex_3.10.40.bb
+++ b/recipes-kernel/linux/linux-toradex_3.10.40.bb
@@ -34,7 +34,7 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/$/_defconfig/'`"
- pushd ${S}
+ cd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake $DEFCONFIG
@@ -48,7 +48,8 @@ do_configure_prepend () {
#Add GIT revision to the local version
head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
printf "%s%s" +g $head > ${S}/.scmversion
- popd
+
+ cd - > /dev/null
}
do_uboot_mkimage_prepend() {