summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/glibc/glibc-2.25/0001-linux-minimum-version-set-to-3.1.10.patch49
-rw-r--r--recipes-core/glibc/glibc_2.%.bbappend3
-rw-r--r--recipes-core/hdmi-hotplug/files/apalis-tk1/hdmi.sh6
-rw-r--r--recipes-core/hdmi-hotplug/files/hdmi.sh2
-rw-r--r--recipes-core/nv-conf/files/nv-conf.service12
-rw-r--r--recipes-core/nv-conf/files/nv-conf.sh24
-rw-r--r--recipes-core/nv-conf/nv-conf-systemd.bb31
7 files changed, 1 insertions, 126 deletions
diff --git a/recipes-core/glibc/glibc-2.25/0001-linux-minimum-version-set-to-3.1.10.patch b/recipes-core/glibc/glibc-2.25/0001-linux-minimum-version-set-to-3.1.10.patch
deleted file mode 100644
index 028f0c6..0000000
--- a/recipes-core/glibc/glibc-2.25/0001-linux-minimum-version-set-to-3.1.10.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 68bc2dbe4ee91ee48bbd398bbbfcae01a9bda7ff Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Mon, 19 Dec 2016 16:57:51 +0100
-Subject: [PATCH] linux minimum version: set to 3.1.10
-
-This allows using glibc 2.24 with the older 3.1.10 L4T kernel.
-
-Set the minimum allowed kernel version to 3.1.10.
-The only conditional which got removed from 2.23 to 2.24 is for kernels
-> 3.0.0
-__ASSUME_FUTEX_LOCK_PI with commit f5c77f78ec03363d5e550c4996deb75ee3f2e32a
-The code mentioned in the commit which makes the conditional unneeded is
-also part of the L4T kernel.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- sysdeps/unix/sysv/linux/configure | 2 +-
- sysdeps/unix/sysv/linux/configure.ac | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/sysdeps/unix/sysv/linux/configure b/sysdeps/unix/sysv/linux/configure
-index cace758..cacb9e7 100644
---- a/sysdeps/unix/sysv/linux/configure
-+++ b/sysdeps/unix/sysv/linux/configure
-@@ -51,7 +51,7 @@ fi
- # set arch_minimum_kernel already, let that override our defaults here.
- # Note that we presume such a fragment has set libc_cv_gcc_unwind_find_fde
- # if appropriate too.
--test -n "$arch_minimum_kernel" || arch_minimum_kernel=3.2.0
-+test -n "$arch_minimum_kernel" || arch_minimum_kernel=3.1.10
- if test -n "$minimum_kernel"; then
-
- user_version=$((`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
-diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
-index 13abda0..b7df956 100644
---- a/sysdeps/unix/sysv/linux/configure.ac
-+++ b/sysdeps/unix/sysv/linux/configure.ac
-@@ -33,7 +33,7 @@ fi
- # set arch_minimum_kernel already, let that override our defaults here.
- # Note that we presume such a fragment has set libc_cv_gcc_unwind_find_fde
- # if appropriate too.
--test -n "$arch_minimum_kernel" || arch_minimum_kernel=3.2.0
-+test -n "$arch_minimum_kernel" || arch_minimum_kernel=3.1.10
- if test -n "$minimum_kernel"; then
- changequote(,)
- user_version=$((`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
---
-2.5.5
-
diff --git a/recipes-core/glibc/glibc_2.%.bbappend b/recipes-core/glibc/glibc_2.%.bbappend
deleted file mode 100644
index 34b6c98..0000000
--- a/recipes-core/glibc/glibc_2.%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/glibc-2.25:"
-SRC_URI_append = " file://0001-linux-minimum-version-set-to-3.1.10.patch"
-OLDEST_KERNEL = "3.1.10"
diff --git a/recipes-core/hdmi-hotplug/files/apalis-tk1/hdmi.sh b/recipes-core/hdmi-hotplug/files/apalis-tk1/hdmi.sh
deleted file mode 100644
index 43c5459..0000000
--- a/recipes-core/hdmi-hotplug/files/apalis-tk1/hdmi.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-export XAUTHORITY=/home/root/.Xauthority
-export DISPLAY=:0.0
-DISPLAY=:0.0 xrandr --output HDMI-0 --auto --primary --output LVDS-0 --auto --right-of HDMI-0
-lxpanelctl restart
diff --git a/recipes-core/hdmi-hotplug/files/hdmi.sh b/recipes-core/hdmi-hotplug/files/hdmi.sh
index 6a3a6dc..43c5459 100644
--- a/recipes-core/hdmi-hotplug/files/hdmi.sh
+++ b/recipes-core/hdmi-hotplug/files/hdmi.sh
@@ -2,5 +2,5 @@
export XAUTHORITY=/home/root/.Xauthority
export DISPLAY=:0.0
-DISPLAY=:0.0 xrandr --output HDMI-1 --auto
+DISPLAY=:0.0 xrandr --output HDMI-0 --auto --primary --output LVDS-0 --auto --right-of HDMI-0
lxpanelctl restart
diff --git a/recipes-core/nv-conf/files/nv-conf.service b/recipes-core/nv-conf/files/nv-conf.service
deleted file mode 100644
index 3226c6b..0000000
--- a/recipes-core/nv-conf/files/nv-conf.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Enable NVIDIA T30 CPU Hot-Plugging
-DefaultDependencies=no
-After=sysinit.target
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/usr/bin/nv-conf.sh
-
-[Install]
-WantedBy=sysinit.target
diff --git a/recipes-core/nv-conf/files/nv-conf.sh b/recipes-core/nv-conf/files/nv-conf.sh
deleted file mode 100644
index 3b34257..0000000
--- a/recipes-core/nv-conf/files/nv-conf.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-# NVIDIA specific init script
-
-# power state
-if [ -e /sys/power/state ]; then
- chmod 0666 /sys/power/state
-fi
-
-# turn off low-power core migration for now
-if [ -e /sys/module/cpu_tegra3/parameters/no_lp ] ; then
- echo Y > /sys/module/cpu_tegra3/parameters/no_lp
-fi
-
-# enable CPU hot-plugging
-if [ -e /sys/module/cpu_tegra3/parameters/auto_hotplug ] ; then
- echo 1 > /sys/module/cpu_tegra3/parameters/auto_hotplug
-fi
-
-# lp2 idle state
-if [ -e /sys/module/cpuidle/parameters/lp2_in_idle ] ; then
- echo "Y" > /sys/module/cpuidle/parameters/lp2_in_idle
-fi
-
-exit 0
diff --git a/recipes-core/nv-conf/nv-conf-systemd.bb b/recipes-core/nv-conf/nv-conf-systemd.bb
deleted file mode 100644
index 735ca0f..0000000
--- a/recipes-core/nv-conf/nv-conf-systemd.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SECTION = "sysinit"
-SUMMARY = "NVIDIA T30 CPU hot-plug configuration and startup"
-# The license is meant for this recipe and the files it installs.
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-PR = "r1"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://nv-conf.sh \
- file://nv-conf.service \
-"
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/nv-conf.sh ${D}/${bindir}/
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/nv-conf.service ${D}${systemd_unitdir}/system
-}
-
-FILES_${PN} += " \
- ${systemd_unitdir}/system \
-"
-
-NATIVE_SYSTEMD_SUPPORT = "1"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "nv-conf.service"
-