summaryrefslogtreecommitdiff
path: root/recipes-bsp/tegrastats/tegrastats.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/tegrastats/tegrastats.bb')
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
new file mode 100644
index 0000000..9795c47
--- /dev/null
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -0,0 +1,31 @@
+SUMMARY = "NVIDIAS tegrastats"
+DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output to a gtk title bar, gives information about cpu use"
+LICENSE = "CLOSED"
+PR = "r3"
+
+RDEPENDS_{PN}-gtk = "pango"
+
+SRC_URI = "file://tegrastats \
+ file://tegrastats-gtk \
+ file://Tegrastats-gtk.desktop "
+
+S = "${WORKDIR}"
+
+PACKAGES = "${PN} ${PN}-gtk"
+
+# Inhibit warnings about files being stripped.
+# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
+WARN_QA_remove = "already-stripped build-deps"
+WARN_QA-gtk_remove = "already-stripped build-deps"
+
+do_install() {
+ install -d ${D}${bindir}/ ${D}/home/root/Desktop/
+ install -m 0755 ${S}/tegrastats* ${D}${bindir}/
+ install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
+}
+
+FILES_${PN}-gtk = " \
+ ${bindir}/tegrastats-gtk \
+ /home/root/Desktop/Tegra* "
+
+FILES_${PN} = "${bindir}/tegrastats"