summaryrefslogtreecommitdiff
path: root/recipes-bsp/tegrarcm/tegrarcm.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/tegrarcm/tegrarcm.bb')
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 186593c..b4864dd 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -1,7 +1,7 @@
SUMMARY = "TegraRCM"
DESCRIPTION = "Utility used to upload payloads to a NVIDIA Tegra based device in recovery mode (RCM)."
SECTION = "bootloader"
-DEPENDS = "libusb1-native libcryptopp-native"
+DEPENDS = "libusb1 libcryptopp"
LICENSE = "NVIDIA-Public"
LIC_FILES_CHKSUM = "file://LICENSE;md5=395fe5affb633ad84474e42989a8e5be"
@@ -10,7 +10,11 @@ BBCLASSEXTEND = "native nativesdk"
SRC_URI = " \
git://github.com/NVIDIA/tegrarcm.git \
+ file://0001-makefile-specify-cryptopp-include-path-relative-to-s.patch \
+"
+SRC_URI_append_class-native = " \
file://0001-configure.ac-link-crypotpp-as-a-static-library.patch \
+ file://0001-cryptopp-use-relative-path-for-cryptopp-headers.patch \
"
SRCREV = "ec1eeac53420de6b34e814ebd28e92099b257487"
@@ -21,9 +25,10 @@ EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
LDFLAGS_append = " -static-libstdc++"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
-EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32 -I${includedir}/cryptopp'"
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+EXTRA_OEMAKE_class-nativesdk = "CC='${CC}' CXX='${CXX}'"
S = "${WORKDIR}/git"
-inherit autotools native
+inherit autotools pkgconfig