summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend b/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
index fced705..bdd2840 100644
--- a/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
+++ b/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
@@ -1 +1,12 @@
DEPENDS = "dpkg-native"
+
+INSANE_SKIP_${PN} += "already-stripped libdir"
+
+python do_unpack () {
+ locals = d.getVar('WORKDIR', True)
+ s = d.getVar('S', True)
+ d.setVar('WORKDIR', s)
+ d.setVar('S', s)
+ bb.build.exec_func('base_do_unpack', d)
+ d.setVar('WORKDIR', locals)
+}