summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch
diff options
context:
space:
mode:
authorGerard Salvatella <gerard.salvatella@toradex.com>2019-04-29 17:46:25 +0200
committerGerard Salvatella <gerard.salvatella@toradex.com>2019-05-02 14:28:45 +0200
commit04e18ad937f96c33dce8123b49de29bea67b49b3 (patch)
tree76178bc0be524a6d72eb68012eb21327fa3079c7 /recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch
parent838010d81f0a3a81be5efd65e5a4c59a1bf2b99d (diff)
weston: drop support for weston 1.x
Maintaining the current bbappend for weston 1.x versions generates an annoying warning in OE (new in thud), since we do not have any recipe for weston 1.x. Given that the current version of weston is 6.0, it doesn't make much sense to keep these patches. Signed-off-by: Gerard Salvatella <gerard.salvatella@toradex.com>
Diffstat (limited to 'recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch')
-rw-r--r--recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch b/recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch
deleted file mode 100644
index c7426a4..0000000
--- a/recipes-graphics/wayland/files/0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 412880dfeb9951f9e807ed36e293805bc97beb32 Mon Sep 17 00:00:00 2001
-From: Alexandre Courbot <acourbot@nvidia.com>
-Date: Thu, 24 Sep 2015 13:19:02 +0900
-Subject: [PATCH 3/6] Add glFinish to DRM backend to avoid tearing
-
----
- Makefile.am | 3 ++-
- src/compositor-drm.c | 2 ++
- 2 files changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 00b74e5..071d540 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -281,8 +281,9 @@ drm_backend_la_LIBADD = \
- $(COMPOSITOR_LIBS) \
- $(DRM_COMPOSITOR_LIBS) \
- $(INPUT_BACKEND_LIBS) \
-- libshared.la \
- $(CLOCK_GETTIME_LIBS) \
-+ $(SIMPLE_EGL_CLIENT_LIBS) \
-+ libshared.la -lrt \
- libsession-helper.la
- drm_backend_la_CFLAGS = \
- $(COMPOSITOR_CFLAGS) \
-diff --git a/src/compositor-drm.c b/src/compositor-drm.c
-index 90cae10..17ba640 100644
---- a/src/compositor-drm.c
-+++ b/src/compositor-drm.c
-@@ -715,6 +715,7 @@ drm_output_repaint(struct weston_output *output_base,
- output_base->set_dpms(output_base, WESTON_DPMS_ON);
- }
-
-+ glFinish();
- if (drmModePageFlip(backend->drm.fd, output->crtc_id,
- output->next->fb_id,
- DRM_MODE_PAGE_FLIP_EVENT, output) < 0) {
-@@ -838,6 +839,7 @@ drm_output_start_repaint_loop(struct weston_output *output_base)
- */
- fb_id = output->current->fb_id;
-
-+ glFinish();
- if (drmModePageFlip(backend->drm.fd, output->crtc_id, fb_id,
- DRM_MODE_PAGE_FLIP_EVENT, output) < 0) {
- weston_log("queueing pageflip failed: %m\n");
---
-2.9.3
-