summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-03 02:50:41 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-05 02:26:20 +0200
commitda8cdb00dcc73ce9cb6809b6732a6a1153accbf5 (patch)
tree9558e454a58580b2d7b48032d1762593a85905cf
parent8fd3244d86911e2f32a2f766798ee6c919ecdb23 (diff)
linux-driver-package: add needed depends
The binary drivers in linux-driver-package have dependencies on gstreamer's base plugins. Add them to DEPENDS, so that they are available during do_rootfs. Addresses: Collected errors: * calculate_dependencies_for: Cannot satisfy the following dependencies for linux-driver-package: * libgstvideo-0.10-0 (>= 0.10.36) * libgstinterfaces-0.10-0 (>= 0.10.36) * libgstpbutils-0.10-0 (>= 0.10.36) * libgstvideo-0.10-0 (>= 0.10.36) * * opkg_solver_install: Cannot install package linux-driver-package. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Dominik Sliwa <dominik.sliwa@toradex.com>
-rw-r--r--jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend b/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
index 09ab04d..73e07ee 100644
--- a/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
+++ b/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
@@ -21,6 +21,8 @@ do_install_append_apalis-tk1 () {
PACKAGES_prepend = "${PN}-gstnvcamera ${PN}-gstnvvidconv-1.0 ${PN}-nvgstjpeg-1.0 ${PN}-gstnvvidconv-0.10 ${PN}-nvgstjpeg-0.10 ${PN}-nvgstapps "
RRECOMMENDS_${PN}_append = " ${PN}-gstnvcamera ${PN}-gstnvvidconv-1.0 ${PN}-nvgstjpeg-1.0 ${PN}-gstnvvidconv-0.10 ${PN}-nvgstjpeg-0.10 ${PN}-nvgstapps"
+DEPENDS = "gst-plugins-base"
+
RDEPENDS_${PN}-gstnvcamera = "libgstvideo-1.0"
RDEPENDS_${PN}-gstnvvidconv-1.0 = "libgstvideo-1.0"
RDEPENDS_${PN}-gstnvvidconv-0.10 = "gstreamer"