summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-01-21 00:33:38 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:07:50 +0200
commitbcf16669f988d0453e2092ca597bbf976898dd69 (patch)
treeaa25206dda750dad22be75b3f4d35e038916afa0
parentbce75f118c0a45b735456a451581e083b9be046f (diff)
cudatoolkit6.5: expand parameter is mandatory now
d.getVar()'s expand parameter is no longer optional and a python exception is raised in do_unpack. While at it, do not redefine the location of S and skip QA warnings caused by the already stripped binary drivers and unusual Nvidia library location. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend b/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
index fced705..bdd2840 100644
--- a/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
+++ b/jetson-tk1/recipes-bsp/binary-drivers/cudatoolkit6.5_21.4.0.bbappend
@@ -1 +1,12 @@
DEPENDS = "dpkg-native"
+
+INSANE_SKIP_${PN} += "already-stripped libdir"
+
+python do_unpack () {
+ locals = d.getVar('WORKDIR', True)
+ s = d.getVar('S', True)
+ d.setVar('WORKDIR', s)
+ d.setVar('S', s)
+ bb.build.exec_func('base_do_unpack', d)
+ d.setVar('WORKDIR', locals)
+}