summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-03-28 16:50:19 +0200
committerMing Liu <ming.liu@toradex.com>2022-03-29 12:11:07 +0200
commitaafc083408d1891edb575ec19157c1c44a2d9a54 (patch)
tree4293da5923ffa24dfedb21bdc7bc9022622fca3c
parentf4c744cd55620e24703c358a15c3511d4d925192 (diff)
tdx-reference-multimedia-image: use weston image feature
There is now a 'weston' image feature introduced in OE, we can use it to install weston related packages and choose SYSTEMD_DEFAULT_TARGET. Also change to use "x11-base" image feature instead of "x11", this ensures x11 init scripts would be installed to image. Related-to: ELB-3477 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index f96528b..66e950b 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -8,12 +8,9 @@ inherit populate_sdk_qt5
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Reference-Multimedia-Image"
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
-
IMAGE_FEATURES += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
- '', d), d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'weston', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11-base', '', d), d)} \
"
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
@@ -32,7 +29,7 @@ APP_LAUNCH_X11:apalis-tk1 ?= "x-window-qtsmarthome"
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- 'weston weston-init weston-examples ${APP_LAUNCH_WAYLAND}', '', d)} \
+ '${APP_LAUNCH_WAYLAND}', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
'weston-xwayland xterm', \
bb.utils.contains('DISTRO_FEATURES', 'x11', '${APP_LAUNCH_X11}', '', d), d)} \