summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-10-07 10:08:07 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-10-10 12:56:18 +0000
commitfb417309b02aeffb89f38e95af1f55d5419f7321 (patch)
treeba964f0b2ff5186beff06de2494b918251368578
parenteeed965025c5abf5a6dd21f0711cc27c554f157b (diff)
dropbear: dont set PACKAGECONFIG to empty
Directly set PACKAGECONFIG is risky, it could override the same variable in other layers, let's change to use PACKAGECONFIG:remove instead. Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-core/dropbear/dropbear_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/dropbear/dropbear_%.bbappend b/recipes-core/dropbear/dropbear_%.bbappend
index 0083f42..587c497 100644
--- a/recipes-core/dropbear/dropbear_%.bbappend
+++ b/recipes-core/dropbear/dropbear_%.bbappend
@@ -3,4 +3,4 @@
# If debug-tweaks is set in IMAGE_FEATURES then enable also weak ciphers.
# With debug-tweaks we allow password less root access, enforcing strong
# ciphers is pointless anyway.
-PACKAGECONFIG = "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "", "disable-weak-ciphers",d)}"
+PACKAGECONFIG:remove = "${@bb.utils.contains('IMAGE_FEATURES', 'debug-tweaks', 'disable-weak-ciphers', '',d)}"