summaryrefslogtreecommitdiff
path: root/recipes-kernel/backports/files/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/backports/files/makefile.patch')
-rw-r--r--recipes-kernel/backports/files/makefile.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-kernel/backports/files/makefile.patch b/recipes-kernel/backports/files/makefile.patch
new file mode 100644
index 0000000..3045e84
--- /dev/null
+++ b/recipes-kernel/backports/files/makefile.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.real
++++ b/Makefile.real
+@@ -90,11 +90,6 @@ modules: backport-include/backport/autoconf.h
+ install: modules
+ @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_DIR) \
+- INSTALL_MOD_DIR=$(KMODDIR) $(KMODPATH_ARG) \
++ INSTALL_MOD_DIR=$(KMODDIR) INSTALL_MOD_PATH=$(INSTALL_MOD_PATH) \
+ modules_install
+- @./scripts/blacklist.sh $(KLIB)/ $(KLIB)/$(KMODDIR)
+- @./scripts/compress_modules.sh $(KLIB)/$(KMODDIR)
+- @./scripts/check_depmod.sh
+- @/sbin/depmod -a
+- @./scripts/update-initramfs.sh $(KLIB)
+ @echo
+ @echo Your backported driver modules should be installed now.
+ @echo Reboot.