summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
-rw-r--r--recipes-graphics/wayland/weston-init/weston.sh7
2 files changed, 12 insertions, 3 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 494db7c..43bc86a 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -1,3 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://weston.sh"
+
PACKAGECONFIG:append:upstream:tdx = " no-idle-timeout"
PACKAGECONFIG:append:upstream:colibri-imx6ull = " use-pixman"
PACKAGECONFIG:append:upstream:colibri-imx6ull-emmc = " use-pixman"
@@ -5,9 +9,7 @@ PACKAGECONFIG:append:upstream:colibri-imx7 = " use-pixman"
PACKAGECONFIG:append:upstream:colibri-imx7-emmc = " use-pixman"
do_install:append:tdx() {
- # profile is from meta-freescale-distro layer but only being installed for fsl,fslc distros
- # we need install it for Toradex distros here.
- install -Dm0755 ${WORKDIR}/profile ${D}${sysconfdir}/profile.d/weston.sh
+ install -Dm0755 ${WORKDIR}/weston.sh ${D}${sysconfdir}/profile.d/weston.sh
# We need run weston systemd service with root user, or else it could not
# access input devices and GPU acceleration hardwares
diff --git a/recipes-graphics/wayland/weston-init/weston.sh b/recipes-graphics/wayland/weston-init/weston.sh
new file mode 100644
index 0000000..89b04ec
--- /dev/null
+++ b/recipes-graphics/wayland/weston-init/weston.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# Set WAYLAND_DISPLAY manually.
+# It will cause app failures if this variable is not set for ssh login.
+if test -z "$WAYLAND_DISPLAY"; then
+ export WAYLAND_DISPLAY="/run/wayland-0"
+fi