summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend16
1 files changed, 9 insertions, 7 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 6baccf4..a7b7710 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -12,11 +12,13 @@ PACKAGECONFIG:append:upstream:colibri-imx7-emmc = " use-pixman"
do_install:append:tdx() {
install -Dm0755 ${WORKDIR}/weston.sh ${D}${sysconfdir}/profile.d/weston.sh
- # We need run weston systemd service with root user, or else it could not
- # access input devices and GPU acceleration hardwares
- # Reference: https://source.codeaurora.org/external/imx/meta-imx/commit/?h=hardknott-5.10.72-2.2.0&id=9e08be758765d4a991e0a440f8abef225be094e3
- sed -i "s/User=weston/User=root/" ${D}${systemd_system_unitdir}/weston.service
- sed -i "s/Group=weston/Group=root/" ${D}${systemd_system_unitdir}/weston.service
- sed -i "s/SocketUser=weston/SocketUser=root/" ${D}${systemd_system_unitdir}/weston.socket
- sed -i "s/SocketGroup=wayland/SocketGroup=root/" ${D}${systemd_system_unitdir}/weston.socket
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ # We need run weston systemd service with root user, or else it could not
+ # access input devices and GPU acceleration hardwares
+ # Reference: https://source.codeaurora.org/external/imx/meta-imx/commit/?h=hardknott-5.10.72-2.2.0&id=9e08be758765d4a991e0a440f8abef225be094e3
+ sed -i "s/User=weston/User=root/" ${D}${systemd_system_unitdir}/weston.service
+ sed -i "s/Group=weston/Group=root/" ${D}${systemd_system_unitdir}/weston.service
+ sed -i "s/SocketUser=weston/SocketUser=root/" ${D}${systemd_system_unitdir}/weston.socket
+ sed -i "s/SocketGroup=wayland/SocketGroup=root/" ${D}${systemd_system_unitdir}/weston.socket
+ fi
}