summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index ea40849..00e69cd 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,17 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://boot.mount"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/boot.mount ${D}${systemd_unitdir}/system/
+ install -d ${D}${sysconfdir}/systemd/system/default.target.wants
+ ln -sf ${systemd_unitdir}/system/boot.mount \
+ ${D}${sysconfdir}/systemd/system/default.target.wants/boot.mount
+}
+
# This allows for udevd automounting with mounts accessible to all.
do_configure_prepend () {
sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
-} \ No newline at end of file
+}
+
+FILES_${PN} += "${sysconfdir}/systemd/system/default.target.wants/*.mount"
+FILES_${PN} += "${base_libdir}/systemd/system/*.mount"