summaryrefslogtreecommitdiff
path: root/recipes-bsp/mwifiexap/mwifiexap_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mwifiexap/mwifiexap_1.0.bb')
-rw-r--r--recipes-bsp/mwifiexap/mwifiexap_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/mwifiexap/mwifiexap_1.0.bb b/recipes-bsp/mwifiexap/mwifiexap_1.0.bb
new file mode 100644
index 0000000..43bb386
--- /dev/null
+++ b/recipes-bsp/mwifiexap/mwifiexap_1.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "MWiFiEx AP mode"
+DESCRIPTION = "Currently wifi chip fw \
+doesn't support mode changes, this creates\
+multiple interfaces on boot"
+
+inherit systemd
+
+LICENSE = "CLOSED"
+
+SRC_URI = "file://mwifiex.conf \
+ "
+
+do_install () {
+ install -d ${D}/etc/modprobe.d/
+ install -m 0755 ${WORKDIR}/mwifiex.conf ${D}/etc/modprobe.d/mwifiex.conf
+}
+