summaryrefslogtreecommitdiff
path: root/recipes-support/libusbgx/libusbgx_git.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-02-02 17:36:05 -0800
committerMax Krummenacher <max.krummenacher@toradex.com>2017-02-08 20:11:18 +0100
commit8e1de4a8a2b0ee50edeca3d72585f1d754a2602a (patch)
tree8a693ad292aaf4884d7431d7dbc2ea1667ae35ae /recipes-support/libusbgx/libusbgx_git.bb
parent439cc110616fb1dbea3c392159f169deedc189cc (diff)
libusbgx: add RNDIS configuration and systemd service for import
Update libusbgx to a version with OS Descriptor support for better interoperability with Windows operating systems. Add configuration using RNDIS with Toradex vendor id. Read serial number and product id from the device tree to configure the USB gadget device. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-support/libusbgx/libusbgx_git.bb')
-rw-r--r--recipes-support/libusbgx/libusbgx_git.bb24
1 files changed, 20 insertions, 4 deletions
diff --git a/recipes-support/libusbgx/libusbgx_git.bb b/recipes-support/libusbgx/libusbgx_git.bb
index 6c85b20..3e81b39 100644
--- a/recipes-support/libusbgx/libusbgx_git.bb
+++ b/recipes-support/libusbgx/libusbgx_git.bb
@@ -4,14 +4,30 @@ LICENSE = "GPLv2 & LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
-inherit autotools pkgconfig
+inherit autotools pkgconfig systemd
DEPENDS = "libconfig"
+EXTRA_OECONF = "--includedir=${includedir}/usbgx"
+
PV = "0.1.0+git${SRCPV}"
-SRCREV = "9e136571aa4b82fe50028d82ebf14541a7c6245f"
-SRC_URI = "git://github.com/toradex/libusbgx.git \
- "
+SRCREV = "566993a7647ed5cb36098f27084fd2d5d1f0f017"
+SRCBRANCH = "os_descriptors"
+SRC_URI = "git://github.com/toradex/libusbgx.git;branch=${SRCBRANCH} \
+ file://usbg.service \
+ file://g1.schema \
+"
S = "${WORKDIR}/git"
+do_install_append () {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/usbg.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sysconfdir}/usbg/
+ install -m 0644 ${WORKDIR}/g1.schema ${D}${sysconfdir}/usbg/g1.schema
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "usbg.service"