summaryrefslogtreecommitdiff
path: root/recipes-core/udev/udev-extraconf_%.bbappend
diff options
context:
space:
mode:
authorLeonardo Graboski Veiga <leogveiga@gmail.com>2017-03-23 14:44:19 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 14:07:39 +0200
commit554adccf11f2ba2947ed221307ddd703c0889967 (patch)
tree94ff2715cb3acf976b40becb021d70df9179ee3c /recipes-core/udev/udev-extraconf_%.bbappend
parent5fe0cebd4347eb19e9cf47ba4dd3803e929402cd (diff)
Configure the read_ahead cache size to optimal value, for the mmcblk devices (eMMC and SD card). The cache values are module specific, tests were run on the pre-built image (BSP V2.7 Beta 1). The measurement of read speed for a range of cache sizes (16kB to 256MB) was made using hdparm -t. Signed-off-by: Leonardo Graboski Veiga <leogveiga@gmail.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-core/udev/udev-extraconf_%.bbappend')
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index e9cf79a..7b03d77 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
+
+SRC_URI_append = " file://hotplug.rules \
+ file://hotplug.sh \
+"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/hotplug.rules ${D}${sysconfdir}/udev/rules.d/hotplug.rules
+
+ install -d ${D}${sysconfdir}/udev/scripts/
+ install -m 0755 ${WORKDIR}/hotplug.sh ${D}${sysconfdir}/udev/scripts/hotplug.sh
+}