summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-17 19:28:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-12-02 15:56:23 +0100
commitd049426c8c76c92716aedec75e008157707c4ac3 (patch)
tree22b977c5fd4d0eb39f8976079e65d272c7a6f91b
parentb26a63011d3bfc4a0f0809a9cf5fd345389d8736 (diff)
linux-toradex-mainline: drop inc file
It is only used by linux-toradex-mainline_5.4.bb, integrate it into that recipe file for clarity. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc27
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_5.4.bb48
2 files changed, 37 insertions, 38 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
deleted file mode 100644
index a41992c..0000000
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Toradex mainline Linux kernel"
-SUMMARY:preempt-rt = "Toradex mainline real-Time Linux kernel"
-SECTION = "kernel"
-LICENSE = "GPLv2"
-
-LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-
-inherit kernel-yocto kernel toradex-kernel-localversion
-
-SRC_URI = " \
- git://git.toradex.com/linux-toradex.git;protocol=https;branch=${KBRANCH};name=machine \
-"
-
-S = "${WORKDIR}/git"
-
-DEPENDS += "coreutils-native lzop-native"
-
-# Additional file deployed by recent mainline kernels
-FILES:${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
-
-KERNEL_CONFIG_NAME ?= "${KERNEL_PACKAGE_NAME}-config-${KERNEL_ARTIFACT_NAME}"
-KERNEL_CONFIG_LINK_NAME ?= "${KERNEL_PACKAGE_NAME}-config"
-
-do_deploy:append() {
- cp -a ${B}/.config ${DEPLOYDIR}/${KERNEL_CONFIG_NAME}
- ln -sf ${KERNEL_CONFIG_NAME} ${DEPLOYDIR}/${KERNEL_CONFIG_LINK_NAME}
-}
diff --git a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
index 9a54626..27bd7cb 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
@@ -1,20 +1,52 @@
+SUMMARY = "Toradex mainline Linux kernel"
+SUMMARY:preempt-rt = "Toradex mainline real-Time Linux kernel"
+SECTION = "kernel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.4:"
+DEPENDS += "coreutils-native lzop-native"
+
LINUX_VERSION ?= "5.4.154"
PV = "${LINUX_VERSION}+git${SRCPV}"
+KBRANCH = "toradex_5.4.y"
+SRC_URI = " \
+ git://git.toradex.com/linux-toradex.git;protocol=https;branch=${KBRANCH};name=machine \
+"
+
SRCREV_machine = "dd7439734dc9ea17674a9c36f0bfa725e7d10736"
SRCREV_machine:use-head-next = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
KCONFIG_MODE="--alldefconfig"
+KBUILD_DEFCONFIG ?= "toradex-imx_v6_v7_defconfig"
+KBUILD_DEFCONFIG:apalis-tk1 ?= "tegra_defconfig"
-KBRANCH = "toradex_5.4.y"
+# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
+KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
+
+inherit kernel-yocto kernel toradex-kernel-localversion
+
+# Additional file deployed by recent mainline kernels
+FILES:${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
-require recipes-kernel/linux/linux-toradex-mainline.inc
+KERNEL_CONFIG_NAME ?= "${KERNEL_PACKAGE_NAME}-config-${KERNEL_ARTIFACT_NAME}"
+KERNEL_CONFIG_LINK_NAME ?= "${KERNEL_PACKAGE_NAME}-config"
-# Don't delete /older/ in the link as /older/ also contains the newest file and we have a stable
-# link
+export DTC_FLAGS = "-@"
+
+do_deploy:append() {
+ cp -a ${B}/.config ${DEPLOYDIR}/${KERNEL_CONFIG_NAME}
+ ln -sf ${KERNEL_CONFIG_NAME} ${DEPLOYDIR}/${KERNEL_CONFIG_LINK_NAME}
+}
+
+#######################################################################
+
+# Don't delete /older/ in the link as /older/ also contains the newest
+# file and we have a stable link
SRC_URI:append:preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/patch-5.4.154-rt65.patch.xz;name=rt-patch \
file://preempt-rt.scc \
@@ -23,10 +55,4 @@ SRC_URI:append:preempt-rt = " \
SRC_URI[rt-patch.md5sum] = "1626836fc6bbff42e463c6a07bfc79b7"
SRC_URI[rt-patch.sha256sum] = "899037547ab272cbb835400633e9c96812c1172845b68479ececc3901eaf6c6d"
-# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
-KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
-
-KBUILD_DEFCONFIG ?= "toradex-imx_v6_v7_defconfig"
-KBUILD_DEFCONFIG:apalis-tk1 ?= "tegra_defconfig"
-
-export DTC_FLAGS = "-@"
+#######################################################################