summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 09:50:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 13:43:27 +0200
commit800e3beb2415365098581f8dcd2d473f7098d35b (patch)
treea5082da4de46ed45df1995607c172d643d523e72
parent9818a0bac82a8059668ab9062deac69c8fae9c56 (diff)
usb-rndis-systemd: drop recipe
The last user of this were the Tegras using the downstream kernel which were dropped. Drop the recipe. Related-to: ELB-2733 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-core/usb-rndis/files/start-rndis.sh13
-rw-r--r--recipes-core/usb-rndis/files/tegra124/start-rndis.sh17
-rw-r--r--recipes-core/usb-rndis/files/usb-rndis.service14
-rw-r--r--recipes-core/usb-rndis/usb-rndis-systemd.bb43
4 files changed, 0 insertions, 87 deletions
diff --git a/recipes-core/usb-rndis/files/start-rndis.sh b/recipes-core/usb-rndis/files/start-rndis.sh
deleted file mode 100644
index e226bbe..0000000
--- a/recipes-core/usb-rndis/files/start-rndis.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-# configures the usb gadget to provide rnidis,
-case "$1" in
- start)
- /sbin/modprobe g_ether dev_addr=00:14:2d:ff:ff:ff host_addr=00:14:2d:ff:ff:fe
- ;;
-
- stop)
- /sbin/modprobe -r g_ether
- ;;
-esac
-
-exit 0
diff --git a/recipes-core/usb-rndis/files/tegra124/start-rndis.sh b/recipes-core/usb-rndis/files/tegra124/start-rndis.sh
deleted file mode 100644
index 13efda3..0000000
--- a/recipes-core/usb-rndis/files/tegra124/start-rndis.sh
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-# configures the usb gadget to provide rnidis,
-case "$1" in
- start)
- echo 0 > /sys/class/android_usb/android0/enable
- echo rndis > /sys/class/android_usb/android0/functions
- echo 1 > /sys/class/android_usb/android0/enable
- ip link set rndis0 up
- ;;
-
- stop)
- ip link set rndis0 down
- echo 0 > /sys/class/android_usb/android0/enable
- ;;
-esac
-
-exit 0
diff --git a/recipes-core/usb-rndis/files/usb-rndis.service b/recipes-core/usb-rndis/files/usb-rndis.service
deleted file mode 100644
index 968d70e..0000000
--- a/recipes-core/usb-rndis/files/usb-rndis.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Load/Configure the kernel driver providing the RNDIS gadget
-Documentation=http://www.linux-usb.org/gadget/ http://permalink.gmane.org/gmane.linux.usb.general/56244
-DefaultDependencies=no
-After=network.target
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/usr/bin/start-rndis.sh start
-ExecStop=/usr/bin/start-rndis.sh stop
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-core/usb-rndis/usb-rndis-systemd.bb b/recipes-core/usb-rndis/usb-rndis-systemd.bb
deleted file mode 100644
index 5cc6521..0000000
--- a/recipes-core/usb-rndis/usb-rndis-systemd.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SECTION = "network"
-SUMMARY = "RNDIS usb client configuration and startup"
-# The license is meant for this recipe and the files it installs.
-# RNDIS is part of the kernel, systemd-networkd is part of systemd
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-PR = "r1"
-
-# Tegra Kernels:
-# The kernel provides with CONFIG_USB_G_ANDROID a composite gadget driver
-# among other with RNDIS functionality.
-# i.MX6 Kernels:
-# The kernel provides with CONFIG_USB_ETH_RNDIS an USB gadget driver which
-# provides RNDIS functionality.
-# Vybrid Kernels:
-# The kernel provides with CONFIG_USB_CONFIGFS_RNDIS an USB gadget driver
-# which provides RNDIS functionality. RNDIS needs to be configured and
-# enabled through configfs, which is done by libusbg (usbg.service)
-
-# This package contains systemd files to configure RNDIS at startup (Tegra
-# and i.MX6), configures a fix IP locally and provides a DHCP server using
-# systemd-networkd
-# Local IP is 192.168.11.1, remote IP is 192.168.11.2
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://start-rndis.sh \
- file://usb-rndis.service \
-"
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/start-rndis.sh ${D}/${bindir}/
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/usb-rndis.service ${D}${systemd_unitdir}/system
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "usb-rndis.service"
-SYSTEMD_AUTO_ENABLE_mx6 = "disable"